Go Down

Topic: How to reset a Mega 2560 via physical button (Read 3120 times) previous topic - next topic

kimptoc

Hi,

My MEGA 2560 is failing to appear when I connect it to a PC. We think we had a failed upload of new firmware.

Now when we connect it, the power light comes on, but the RX/TX lights don't flash and its not recognised by the computer when connected.

I see there is a button marked reset next to the power light on the Arduino.

How do we use that - tried just pushing it, when powered, and also while connecting it to a PC, but doesn't seem to have helped.

Thanks in advance for any tips.
Chris

ballscrewbob

It simply restarts the sketch.

However if used correctly (some timing may be required) it can also often be used to upload a new sketch in some errant boards just prior the UPLOAD phase.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

CrossRoads

Press & hold Reset, start a code download. Release Reset when the IDE shows "compiled xxx of 128xxx" bytes.
Timing can  be easier if you select File:Preferences and turn on verbose outputs.
Might take a couple of tries to get the release timing correct.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

CrossRoads

If that doesn't work try the Loopback test, it's a topic at the top of this forum.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

DrAzzy

Reset button just resets the '2560 - whether the computer detects it does not depend on the state of the 2560, but on the serial adapter. Does the port appear under tools -> port menu when it's plugged in? If not, that is a bad sign for the hardware.

Is it based on 16u2 serial adapter (like official boards or faithful clones)? What were you doing before it stopped working?  Is the USB cable known good? Bad USB cables seem to be the plague of the year (last year's was ftdigate).
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

kimptoc

Thanks all - the port does NOT appear under tools -> port menu when connected via USB to a Mac and also when linked to a raspberry PI running raspbian  :(
I think the problem started after we did a firmware upgrade/upload (via FarmBot OS - https://software.farmbot.io/v1.0/docs/arduino-firmware )

Not sure what its based on :(

kimptoc

#6
Jun 10, 2017, 10:31 pm Last Edit: Jun 10, 2017, 10:49 pm by kimptoc
I have now tried the loopback test ( http://forum.arduino.cc/index.php?topic=73748.0 ) , still no joy - port does not appear on menu, nor any messages in /var/log/messages and dmesg.

The L/LED does come on and stays on now (don't think it was doing this before).

Have also got another board, which works fine.  I noticed that the other/working one has the Arduino -/+ logo on it.  Perhaps that means the faulty one is a clone. (see image)

https://www.flickr.com/photos/kimptoc/34378433154/

Wawa

Last month my Mega clone was not detected anymore (after an upgrade of the IDE?).
Too lazy to sort it out.
Just deleted the IDE, and re-installed it.
After that it worked again.
Leo..

kimptoc

Thanks - tried that, but no joy.  The working one still works and the dead one is still dead :(

Time to see if it can be returned...

Go Up