Go Down

Topic: Problème de valeurs faibles avec un capteur d'humidité (Read 1 time) previous topic - next topic

tschvartz

Voilà 2 photos...

Artouste


tschvartz

Sur le pot ajustable il est noté 3362... C'est ce que tu veux ?

Artouste

Sur le pot ajustable il est noté 3362... C'est ce que tu veux ?
8)
Jai mal posé ma question ?
surement ! 8)
Je procède donc différemment :

Il y a quoi de marqué sur le truc noir à coté du pot ajustable bleu ?
c'est mieux ? :D

tschvartz

OK désolé je n'avais pas compris, je débute.

Donc c'est noté :

LM393
8AK
1608H

Merci de ta patience

Artouste

Donc c'est noté :
...
LM393
...
Merci de ta patience
:D
Tu es en présence d'un simple comparateur
En sortie tu ne ne récupère donc rien d'autre qu'un signal  0/1  , le seuil de basculement entre 0/1 est réglable par le pot bleu.

pour faire simple :
avec ton module , tu ne peux detecter que le passage entre "sec/pas sec" ou "humide/pas humide"  8) , mais pas connaitre/acquérir valablement les  variations entre "sec et humide" 

J-M-L

@artouste

 Non ce n'est pas le cas - il y a une broche de sortie analogique et une tout ou rien gérée par le potar et comparateur

Il faut bien sûr brancher l'entrée analogique de l'Arduino sur la sortie analogique, pas digitale

Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

Artouste

@artouste

 Non ce n'est pas le cas - il y a une broche de sortie analogique et une tout ou rien gérée par le potar et comparateur

Il faut bien sûr brancher l'entrée analogique de l'Arduino sur la sortie analogique, pas digitale


bonjour J-M-L
Je me suis mal exprimé
ce genre de module (j'en ai) dispose de 2 sortie
une Digitale en sortie du comparateur
une Analogique qui n'est rien d'autre que le point milieu d'un pont diviseur (branche fixe VCC à 10K)
c'est quasi inexploitable en analogique


BrUnO14200

J'utilise les mêmes dans ma serre. Je convertis les données en % pour que ça soit plus parlant.

J'arrive à 0% soit 1024pts jusqu'à 80% (env 200 pts) ...

Peut être un capteur défectueux ?

Je rejoins ce que dit Artouste concernant leur utilisation, faut bien moyenner.
Personnellement je m'en sers plus de comparaison avant/après arrosage que pour comparer l'humidité entre 2 zones avec 2 capteurs  ( je sais pas si je m'explique bien ^^ ).
Ma couveuse :https://forum.arduino.cc/index.php?topic=571843.0

tschvartz

J'utilise les mêmes dans ma serre. Je convertis les données en % pour que ça soit plus parlant.

J'arrive à 0% soit 1024pts jusqu'à 80% (env 200 pts) ...

Peut être un capteur défectueux ?

Je rejoins ce que dit Artouste concernant leur utilisation, faut bien moyenner.
Personnellement je m'en sers plus de comparaison avant/après arrosage que pour comparer l'humidité entre 2 zones avec 2 capteurs  ( je sais pas si je m'explique bien ^^ ).
Merci pour toutes vos réponses.

Si je comprend bien je prend la valeur "à sec" et la valeur "dans l'eau" de mon capteur et je converti ces deux valeurs en 0 et 100 et je m'en sert comme référence ?

Merci beaucoup pour vos différents partages très constructifs.

Bonne journée,

Artouste

Merci pour toutes vos réponses.

Si je comprend bien je prend la valeur "à sec" et la valeur "dans l'eau" de mon capteur et je converti ces deux valeurs en 0 et 100 et je m'en sert comme référence ?

Merci beaucoup pour vos différents partages très constructifs.

Bonne journée,
bonsoir
en fait je pense que tu veux utiliser ton module/capteur pour déterminer/apprécier "la conductivité du substrat" = savoir si la terre où est "enfoncé" la sonde est +/- sèche/humide ?
Dans un pot rempli de terre ( NB : ça ne marche pas avec un pot rempli de fer ! 8) )
La résistance de la terre(substrat)  entre tres humide et tres seche evolue dans des proportions importantes entre les 2 electrodes de la "sonde" , la geometrie de la sonde est importante dans l'équation.

De plus il faut prendre bien soin à ne pas alimenter  la sonde en permanence sous risque de destruction (tres) rapide :
 
Une pas trop mauvaise solution simple est de contrôler l'alim du module par un pin arduino en output le temps de faire qq acquisitions , et de ne faire les acquisitions que très épisodiquement ( le phénomène étant d'évolution  lente)
 



Go Up