Go Down

Topic: Library Manager can't install/update libraries (Read 2174 times) previous topic - next topic


Recently my arduino ide became unable to install new (or update current) libraries through the library manager. I've searched all around but no one seems to have the same problem.

Here is the error it spits out:

Code: [Select]
java.lang.RuntimeException: java.nio.file.AccessDeniedException: C:\Users\Shadow58624\Documents\Arduino\libraries\arduino_18956
 at cc.arduino.contributions.libraries.ui.LibraryManagerUI.lambda$onInstallPressed$1(LibraryManagerUI.java:231)
 at java.lang.Thread.run(Thread.java:745)
Caused by: java.nio.file.AccessDeniedException: C:\Users\Shadow58624\Documents\Arduino\libraries\arduino_18956
 at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:83)
 at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
 at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)
 at sun.nio.fs.WindowsFileSystemProvider.createDirectory(WindowsFileSystemProvider.java:504)
 at java.nio.file.Files.createDirectory(Files.java:674)
 at java.nio.file.Files.createAndCheckIsDirectory(Files.java:781)
 at java.nio.file.Files.createDirectories(Files.java:767)
 at processing.app.helpers.FileUtils.createTempFolder(FileUtils.java:109)
 at processing.app.helpers.FileUtils.createTempFolder(FileUtils.java:97)
 at processing.app.helpers.FileUtils.createTempFolder(FileUtils.java:93)
 at cc.arduino.contributions.libraries.LibraryInstaller.install(LibraryInstaller.java:111)
 at cc.arduino.contributions.libraries.ui.LibraryManagerUI.lambda$onInstallPressed$1(LibraryManagerUI.java:227)
 ... 1 more

I've noticed the access denied error and went to the folder and found it was in read-only mode, so i changed it. So it happens that as soon as i close the properties window it changes back to read-only.

Is this an IDE problem or something with my computer?

I'd apreciate any help. Thank you.


Sounds more like a computer issue than in IDE.

BTW thanks for using the code tags.
So nice to see.

A little more info though if you dont mind such as OS and type of AV / Security installed and user level on the computer.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


I just had a similar if not the same problem
library manager couldn't download the index.json file ....or anything else
same problem with board manager

solved in configure java > network settings > changed from "Use browser settings" to "direct connection"


I just had a similar if not the same problem
solved in configure java > network settings > changed from "Use browser settings" to "direct connection"
I had the same problem but changing java settings didn't help :-(

I spotted a thread in my Windows10 Protection Settings and added Java to "trusted File Access"
After this, I was able to Download librarys again.

Best Regards


Thanks for taking the time to share your solution RobinBlood. I'm sure anyone else with this error who finds the post while searching for a solution will be very grateful. I'm glad to hear you got Library Manager working. Enjoy!


Thank you RobinBlood, I had the same problem and your post helped me to solve it!

Go Up