Go Down

Topic: how to choose different ports in sketch? (Read 1 time) previous topic - next topic


I downloaded Arduino sketch onto a Linux machine, and it only lists dev/ttyS0 under the Tools/Serial Port menu. How can I tell it to find a different port (I need it to find one of the USB ports, not the 9 pin)? I've searched through as much source code as I have access to, and I can't figure out how to fix it that way. Thanks for your help,


Available com ports are update when you plug the Arduino in, or unplug it.

If that is not happening for you, no amount of changing of the Arduino source code will cause the necessary FTDI drivers to install themselves.


Hi, I have a similar intermittent issue on Linux/Ubuntu. If the IDE is already running and I plug in the Arduino USB connection it is not always immediately (after a few seconds waiting) recognized. Saving my work and restarting the IDE (closing all the IDE windows) seems to do the trick, then /dev/ttyUSB0 appears under the serial port menu.


I have an Arduino Bluetooth, and turning the microcontroller on doesn't seem to update the serial ports, no matter what order I open the IDE in. I tried it on a Mac and that worked just fine.  

Thanks for your advice,

Go Up