Go Down

Topic: Upload on Windows 64bit - Stuck (solved) (Read 702 times) previous topic - next topic

danass

Jul 10, 2017, 04:27 pm Last Edit: Jul 10, 2017, 05:45 pm by danass
Hi
I can't upload.
It starts uploading, i see blinking light on the arduino.
But it never finishes and stay on "Uploading.." states for long minutes until eventually saying it can't upload.

Though :
1) Arduino is recognized on the COM 4
2) It recognizes the right type of board (Leonardo)
3) I can open the Serial and get data from the previous code that was uploaded.
4) I can upload using a different computer on the board
5) This is a genuine Arduino Leonardo.
6) My usb cable is working.
7) My usb port is working too.
6) I'm using Arduino 1.8.3



pert

Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch  > Upload
  • After the process fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

danass

#2
Jul 10, 2017, 05:14 pm Last Edit: Jul 10, 2017, 05:46 pm by danass
Thx for your answer
here are my errors
Code: [Select]

Arduino: 1.8.3 (Windows Server 2012 R2), Board: "Arduino/Genuino Uno"

Archiving built core (caching) in: C:\Users\ADMINI~1\AppData\Local\Temp\arduino_cache_52728\core\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a
Sketch uses 5964 bytes (18%) of program storage space. Maximum is 32256 bytes.
Global variables use 401 bytes (19%) of dynamic memory, leaving 1647 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\ADMINI~1\AppData\Local\Temp\arduino_build_798991/A6v0.1.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2014 Joerg Wunsch

        System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

        Using Port                    : COM4
        Using Programmer              : arduino
        Overriding Baud Rate          : 115200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x47
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x6f
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x74
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x20
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x72
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x70
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x6f
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x6e

avrdude done.  Thank you.

An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


septillion

Why was step 4 so hard? :/

Did you do a loopback test?
Use fricking code tags!!!!
I want x => I would like x, I need help => I would like help, Need fast => Go and pay someone to do the job...

NEW Library to make fading leds a piece of cake
https://github.com/septillion-git/FadeLed

DrAzzy

You say it's a genuine Leonardo. But you've selected Uno from the tools -> board list instead of Leonardo.
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

danass

Oh my god
i was so stupid.
Didnt put the right board.

My fault
Mea culpa
Sorry

Coding Badly


There are two kinds of Arduino users: those who have made the same mistake and those who have made the same mistake but claim they would never do such a thing.  You are in good company.


Go Up