Go Down

Topic: Unable to use AVRISP MKII to burn bootloader (Read 23741 times) previous topic - next topic


Unable to use AVRISP MKII to burn bootloader

Arduino ISP V12, WinXP completely current.

I have newly purchased an AVRISP MKII because I have accumulated two Arduinos that SEEM to have corrupted bootloaders.  My system automatically installed drivers and report the device to be working properly and enabled.  When I attempt to burn a bootloader to either the Atmega8 NG or the Atmega168 NG, I get the same error:

avrdude: usbdev_open(): did not find any USB device "usb"

The device manager shows the driver as being Jungo/AVRISP MKII, and the Properties/Driver tab shows it to be Jungo LTD ver.  5/6/2005.  Is this a case of the wrong driver having been installed?  If so, which is the right driver?  I have not used the  AVRISP MKII in any other context, nor can I find a reference to this problem in this forum, nor elsewhere.

BTW, the NG is connected, externally powered, and the AVRISP shows both indicators green.



I'm guessing that you have the AVR Studio / ATmel drivers for the AVRISP mkII installed.  Unfortunately, avrdude (which the Arduino IDE uses to burn the bootloader) uses a different driver for the ISP, and only one can be installed at a time.  You'll need to uninstall your current AVRISP mkII drivers and use the libusb ones, which should be included in the Arduino distribution.  

Alternatively, you can use AVR Studio to burn the bootloader.  The fuse and lock information is in the boards.txt file in the hardware/ sub-directory of the Arduino application directory.


Thanks mellis, it is as you say.  I have recently begun using AVR Studio to hack and develop C/C++ modules for Arduino.  Guess it had been so long since I burned a 'loader that I didn't notice the loss of that functionality when I installed AVR Studio, and didn't correlate the two events.  Shoulda guessed...  Anyhoo I'll stick with AVR Studio for burns.


Mark Bramwell

Are you sure it is a MKII or is it a v2 ?

Today I received from a HK company (via eBay) a STK500 USB clone.

It uses an USB serial chip to make it look like a com port.  It took me about an hour to figure out what was going on because it arrived with ZERO documentation.

I determined that I had to edit the boards.txt file and add these lines:

avrisp.name=HK-AVR ISPv2

Do an eBay search for "ATMEL STK500 Programmer for Arduino & Freeduino Board" to see what I got.

FYI:  Switch 1 should be off, Switch 2 should be ON.

Tonight a built a boarduio and programmed a bootloader on a new ATMEGA chip via the ISP plug.  I am now able to use the Arduino software ok on that newly bootloaded chip. :D


Dec 13, 2008, 02:53 am Last Edit: Dec 13, 2008, 02:54 am by gigadork Reason: 1
Thanks for the tips!  Now that I got it figured, I think I'll stick with the config I have.  I had been using an RS232 AVRISP MKI and recently went to the AVRISP MKII both to go USB and to go 6 pin IDC rather than 10. I will be doing direct burns through AVR Studio, ongoing, and once I found the bootloader executable, it's cake... and this way I do all my direct burns the same way!  Only little minds think consistency a hobgoblin.

If the two IDEs can't play nice, I'll just keep 'em separated!

Hmm, now that I think of it, maybe I can use the old RS232 MKI with one of SparkFun's IDC10-6 breakout boards as a completely separate system for burning from the Arduino IDE...  Naah, it's to much trouble, who cares? I have to burn a 'loader about twice a year.  Problem freakin' solved, thanks again Mellis!


PS:  RayG and GigaDork are the same human, one is Work-me and the other is Me-me.  Don't ask which is which, I forget.


Hi, i have the same issue,
In avr studio, it seems to work, but still no able to download sketch?
in AVR studio
Icon AVR, Program, FLASH, browse ATmegaBOOT_168.hex
Is this all??? any fuse to burn?


Jan 22, 2009, 03:33 am Last Edit: Jan 22, 2009, 05:57 am by patgadget Reason: 1
Ok Found it, i had to write the fuse bit to get it working
note: It only work from AVR STUDIO and 1 out of 5 chip i can't burn!!!


Jan 22, 2009, 04:54 am Last Edit: Jan 22, 2009, 04:55 am by patgadget Reason: 1
Got this message:
avrdude: usbdev_open(): did not find any USB device "usb"

still not able to burn bootloader with arduino still have the jungo issue, i try to delete the AVRISP mkII driver then re installing it from the arduino directory arduino-0012\hardware\tools\avr\utils\libusb\bin and still got the jungo issue? i try to change the
Code: [Select]
avrispmkii.name=AVRISP mkII

Code: [Select]
avrispmkii.name=AVRISP mkII

in the programmers.txt file
but still won't work, it make arduino crash, any idea to burn from arduino?


Hi, I'm able to use my avrispmkII with avrdude that came with winavr, but I am unable to burn the bootloader using the arduino IDE...


Hi is there any solution to this problem to use af AVRISP mkII to program a bootloader to a 168?? i have made the Arduino selv made board under hardware??



Where can I find the avrdude "libusb" drivers for the AVRISPmkII programmer in the arduino folder?  I am using arduino0021 right now.

And how would I burn the libusb driver onto the avrispmkII programmer?




What is the solution to this!
I've got a custom mega1280 compatible board and want to program with the arduino IDE and a AVRISP mkII

Its all well and good to install AVR Studio, but what the hell is the issue with the arduino IDE?

most the jungo driver be installed?

is the lib usb driver the one here:

is there an OS compatibility issue?

i get this message no matter what i try...
avrdude: usbdev_open(): did not find any USB device "usb"


Tried installing the libusb drivers clean to no avail.
I'm using on 64bit Win 7, but its has 'lots' of crap on it...

Tried in on a (media PC) 32bit Win 7 machine and it worked fine...

When I toast one this ill try it clean (i.e. no history of AVR Studio, or other dev tools) and it should determine if there is some issue with the 64bit os.

Will post back.

Go Up