Go Down

Topic: [SOLVED] Arduino_debug.exe on 64-bit Windows: Silently failing verification (Read 986 times) previous topic - next topic

5parrowhawk

Hi,

I seem to be having this problem with CLI verification on Windows using arduino_debug.exe.

Edit: I'm running 64-bit Windows 10, and Arduino 1.8.0.

I've created an empty default sketch using the GUI, and am able to verify it.

However, when I try to use arduino_debug.exe --verify to verify the same sketch:

Code: [Select]

arduino_debug --verbose-build --verify CLIUpTest.ino


it displays the following output:

Code: [Select]

Loading configuration...
Initializing packages...
Preparing boards...
Verifying...


and then exits.

The error code is 1 (verification or upload failed). No error messages are displayed. (Why?)

I am running arduino_debug from the same directory as the .ino file, with my PATH environment variable set to the location of arduino_debug.exe.

Do I need to set any other environment variables? I was under the impression that installing Arduino automatically set those variables appropriately.


5parrowhawk

Try adding the --board option with the fqbn (e.g. arduino:avr:uno).

Details: https://github.com/arduino/Arduino/blob/master/build/shared/manpage.adoc#options
Hi. Thanks for the quick reply. I was using that page as a reference, but this command produces the same result:

Code: [Select]
arduino_debug --verbose-build --board arduino:avr:mega:cpu=atmega2560 --port COM3 --verify CLIUpTest.ino

(I have already confirmed that my board is a MEGA 2560 connected to port COM3.)

pert

The problem is that Arduino IDE 1.8.0 and 1.8.1 fail to verify a sketch if the absolute path to it is not specified, even though you are running the command from the sketch folder. You should be able to solve the problem by upgrading to Arduino IDE 1.8.3. If for some reason you need to continue to use 1.8.0 then you will need to specify the path to the sketch.

5parrowhawk

The problem is that Arduino IDE 1.8.0 and 1.8.1 fail to verify a sketch if the absolute path to it is not specified, even though you are running the command from the sketch folder. You should be able to solve the problem by upgrading to Arduino IDE 1.8.3. If for some reason you need to continue to use 1.8.0 then you will need to specify the path to the sketch.
Ah, that solved the problem. Thank you!

pert

Glad to hear it's working for you now!

I guess that was a bug in those IDE versions. I ran into this a couple months ago in my Travis CI tests and definitely wasted some hours trying to figure out why my builds were failing for no reason. Luckily after looking back over this thread I remembered there was something like that with certain IDE versions and found a comment about it in my script.

Go Up