Go Down

Topic: Arduino 21 Software - Arduino cannot run because.. (Read 19002 times) previous topic - next topic

tomjung09

Oct 18, 2010, 05:44 am Last Edit: Oct 18, 2010, 05:45 am by tomjung09 Reason: 1
Arduino cannot run because it could not create a folder to store your sketch book.  I got this after unzipping the download and trying to run the exe.

I have full permissions to the AppData/Roaming folder which my registry points to.

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1255030967

I'm not sure what else to do.  Anyone have any ideas?

I'm running windows vista 64 bit

PaulS

Use the File + Preferences menu item to see where the Arduino application thinks sketches should be stored. It's the top field on the dialog. Make sure that that is a location that you do have permission to write to.
The art of getting good answers lies in asking good questions.

tomjung09

Hi Pauls,
Thank you so much for the reply. I'm a little confused though on the instructions.

The application won't open up at all for me to get to the file menu.  I get the initial start up screen and before anything actually opens the error occurs.

mellis

Do you end up with a preferences.txt file, in the AppData/Roaming directory?  The sketchbook should be written elsewhere, like your Documents folder.  The sketchbook location it's trying to use should be shown in preferences.txt (sorry, I don't remember the exact key name).  You could also try deleting preferences.txt, in case it's old and has an incorrect sketchbook location.

tomjung09

Okay! I feel like I'm getting real close on this. I found the preferences file and deleted it.  Didn't work. I looked for the sketchbook entry but I can't find it.  I don't know if I'm blind or what but this is what I have in my file:



target=arduino
export.application.platform.windows=true
preproc.save_build_files=false
preproc.substitute_floats=true
run.options=
editor.window.width.min=400
run.display=1
editor.divider.size=2
serial.port=COM1
preproc.enhanced_casting=true
editor.divider.size.windows=2
editor.font=Monospaced,plain,12
console.auto_clear=true
console.output.file=stdout.txt
editor.keys.home_and_end_travel_far.macosx=true
last.sketch.count=0
editor.window.height.min=530
export.application.platform=true
editor.keys.alternative_cut_copy_paste.macosx=false
export.application.stop=true
editor.window.height.min.macosx=450
serial.parity=N
serial.databits=8
board=atmega328
preproc.output_parse_tree=false
editor.external=false
editor.indent=true
upload.using=bootloader
run.present.bgcolor=#666666
preproc.web_colors=true
editor.tabs.expand=true
run.present.stop.color=#cccccc
preproc.color_datatype=true
editor.keys.shift_backspace_is_delete=true
editor.window.height.min.windows=530
export.application.platform.linux=true
export.application.platform.macosx=true
export.applet.separate_jar_files=false
editor.antialias=false
editor.tabs.size=2
console.error.file=stderr.txt
preproc.substitute_unicode=true
console=true
run.present.exclusive.macosx=true
console.lines=4
run.options.memory.maximum=256
browser.linux=mozilla
update.check=true
run.window.bgcolor=#F0F0F0
editor.keys.home_and_end_travel_far=false
editor.keys.alternative_cut_copy_paste=true
export.delete_target_folder=true
platform.auto_file_type_associations=true
editor.caret.blink=true
serial.stopbits=1
editor.window.width.default=500
serial.debug_rate=9600
run.options.memory.initial=64
preproc.imports.list=java.applet.*,java.awt.Dimension,java.awt.Frame,java.awt.event.MouseEvent,java.awt.event.KeyEvent,java.awt.event.FocusEvent,java.awt.Image,java.io.*,java.net.*,java.text.*,java.util.*,java.util.zip.*,java.util.regex.*
run.options.memory=false
export.application.fullscreen=false
editor.invalid=false
editor.font.macosx=Monaco,plain,10
editor.window.height.default=600
console.length=500
run.present.exclusive=false


Does that look right?

mellis

Hmm, there should be an entry like:
sketchbook.path=/Users/mellis/Documents/Arduino

Maybe try adding it with a directory that you want to use for the sketchbook?  Make sure you create the directory first.

tomjung09

Yep that was it.  I think the whole issue was that my Documents folder registry key was set to a location that didn't exist (I had it set to drive F which no longer exists)

quinezhu

#7
Jan 05, 2011, 08:06 am Last Edit: Jan 05, 2011, 08:07 am by quinezhu Reason: 1
I got the same problem with 0021 today.  Also the full permissions to the AppData/Roaming folder.

It works after changing sketchbook.path and settings.path according to the following page:
http://processing.org/bugs/bugzilla/1016.html


Go Up