Go Down

Topic: Help get Arduino 21 installed on my Ubuntu machine (Read 13516 times) previous topic - next topic


I've pored over dozens of posts similar to this topic, but I am LINUX and C illiterate, and am struggling.  I need to get Arduino 0021 onto my Ubuntu V10.10 machine, in order to drive my Aduino Uno.  I tried installing Arduino from the Ubuntu Software Center, but it only provides Version 0018.  I tried loading/istalling it via "sudo apt-get" from a Command Line in a Terminal, but again it only came up with V.18.  I downloaded Arduino 0021 from Arduino.cc, and extracted it, but don't know how to get it to install.  I read about Debian and downloaded 0021+dfss-2.debian and got it to extract, but cannot figure out how to get debian to install it.  Can anyone give me really simple advice on how to get either of these downloads to install?  Any assistance will be appreciated...thanks in advance.


Dec 25, 2010, 06:16 am Last Edit: Dec 25, 2010, 10:16 pm by mrtaylor Reason: 1
Here is what I just did.

Downloaded version 0022 from:
   // it downloaded to my /home/mark/Downloads directory

// open terminal from ubuntu menu

// go to downloads directory
cd ~/Downloads

// untar the downloaded file
tar -vxzf arduino-0022.tgz

// change directory to replace librxtxSerial library    
cd arduino-0022/lib
// backup original lib
mv librxtxSerial.so librxtxSerial.so.orig

//find librxtxSerial library that works for this system
find / -ls 2>&1 | grep -i librxtxSerial

if librxtSerial library is not found somewhere in a /usr/lib subdirectory
   //  this will require root  password
  sudo apt-get install arduino
  // rerun the find command


// found it in /usr/lib/jni
// copy it to arduino-0022/lib directory
cp /usr/lib/jni/librxtxSerial.so .

// go up one directory
cd ..                            

// exec arduino software



Thanks very much, MrTaylor.  I appreciate your taking the time to lay that out for me.  Will give it a try.  Cheers, and Happy Holidays.


Well, Mark, I got about halfway through it (I did have to add a z to the tar command, then it seemed to work).  Later, it seems to have encountered trouble after I told it to search for the serial library, and it asked me for my password:

fred@fred-desktop:~/Downloads/arduino-0022/lib$ sudo find / -ls|grep -i librxtxSerial
[sudo] password for fred:
find: `/home/fred/.gvfs': Permission denied
6079956   48 -rw-r--r--   1 fred     fred        48304 Dec 24 14:12 /home/fred/Downloads/arduino-0022/lib/librxtxSerial.so.orig
6078967   48 -rw-r--r--   1 fred     fred        48304 Oct  2 13:17 /home/fred/Desktop/arduino-0021/lib/librxtxSerial.so
find: /proc/2/task/2/exe: No such file or directory
It repeated the "No such file or directory" line for a couple of hundred different task numbers.

I'm gathering that I am lacking some sort of permission that was required. Am I hosed?  Do I need to go in and restore something on that lib that I backed up?

Again, I appreciate your help.  If it is "a bridge too far" for a lame-o like me to do this, please feel free to tell me so.  Tnx, fred


replace find command with:

find / -ls 2>&1 |grep -i librxtxSerial

This should filter out the Permission denied messages


The install Ubuntu without package on the playground works for me.  Basically install the pre-requisites using apt or sysnaptic and just extract the arduino download to your home folder (do not use sudo, it will effectively make it read only to the ordinary user).  Never had to change permissions or add users to groups etc.

0022 is out ? That passed me by......


Thanks, Pluggy, for the alternate suggestion, but I am so uninitiated in Linux I am afraid I'd screw it up.
I, too, was surprised to learn from mrtaylor that 0022 was out.
mrtaylor, I changed the Find command per your suggestion, and the only two librxtxserial files that it found were in the Arduino 0021 and 0022 packages.  I initiated a file search of my own under the Places pulldown, and those were the only two found.  Does this mean that when my son built this machine that he may have missed a library file?  I think I've successfully used the USB port on this machine in the ast, but am not sure of that.


You might trying running Arduino 0021 or 0022 with the RXTX library that comes with it.  That is, move the .orig file back to its previous name:

// change directory to replace librxtxSerial library    
cd arduino-0022/lib

// restore original lib
mv librxtxSerial.so.orig librxtxSerial.so

Then run the arduino file.  If that doesn't work, you can install the "RXTX" package in Synaptic Package Manager, and then follow the instructions about replacing the RXTX from the Arduino software with the one from the distribution's package.


install arduino version 0018 from the ubuntu repositories

//  this will require root  password
sudo apt-get install arduino

Then rerun the find command


Dec 25, 2010, 11:26 pm Last Edit: Dec 25, 2010, 11:29 pm by raron Reason: 1
I downloaded Arduino 0021 from Arduino.cc, and extracted it, but don't know how to get it to install

Maybe I'm just lucky, but that's what I did too, and you are almost there if you have done that. Just go to the directory you extracted it to. I'm using /home/myusername/arduino-0021/ - so I type "cd arduino-0021/", and then start it by typing:


In the terminal. Or just write "./a" - then hit TAB, and it should auto-complete.

Using Ubuntu 10.04 64-bit btw. Also 9.10 on a 32-bit ubuntu.


SUCCESS!  0022 ran.  I was able to select the Uno board.  I successfully uploaded a sketch.
Thanks all who helped, particularly mrtaylor, who invested a lot of time.  You've made this old man happy.  God bless.



Running Kubuntu 10.10 amd-64 Arduino UNO with -0022.  Anyone having problem with reading serial data from the UNO board?  I was trying to work through the programs "Getting started with Arduino" book and anything that reads serial data back hangs up.  If I put a large delay 100 or more I can read the data on the serial monitor.

Another problem, when I installed the Processing language it somehow wipes out arduino -0022 and makes it -0018 complete with Icon on the desktop!  I forget the specifics but I have to run -0022 from it's directory to get it to work again.
Arduino UNO R3


Serial problems on the Uno can usually be cured by upgrading the 8U2 firmware.  

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1285962838 see post #10 especially.

Go Up