Go Down

Topic: 3020 timeout after 400ms (Read 15121 times) previous topic - next topic



Please stop cross posting.
Create your own threads and use the posts at the top of the forums to see what information you should be including. And deleting you other posts.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


Honestly, I do not understand you are hitting me. I did create my own thread after I carefully went through this forum and I have linked all posts related to my question there.

The only answer I get in the forum was from guy, who is not familiar with Chrome app. So he didn't help me with his answer. Then, I have tried to ask in other threads if anyone get the solution of the problem, because there is no *Solved* label.

Keep in mind, I do pay for the Chrome app monthly and only help and support is: Do not ask others! You see it as correct way? I do not.

So, are you able to help or advice me, how to solve the problem? Or can you connect me to someone, who is? That would be helpful.


May 08, 2019, 05:00 pm Last Edit: May 08, 2019, 05:09 pm by dysan
Is there an  solution for this issue yet, encountering the same issues (again on a dell 11" chromebook)
Refreshing the browser and switching from ttyACM0 to ttyUSB0 fixes the problem (for 1 write though)


i am having the same 3020 timeout thing....when is somebody going to fix it



May 17, 2019, 02:11 pm Last Edit: May 17, 2019, 02:14 pm by Enderdraak
I am having the issue to with AFAIK a arduino Nano clone. I am not sure cuz I was not the one to buy or unpack it.
As far as I can see it is a crome issue. I can read the monitor fine until I try to upload something, can it be that there goes something wrong with the reset? of should the time out timer be extended a little, to give the arduino a little more time to overwrite.

it tells me:

/home/builder/opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware /home/builder/opt/arduino-builder/hardware -hardware /home/builder/.arduino15/packages -tools /home/builder/opt/arduino-builder/tools -tools /home/builder/.arduino15/packages -built-in-libraries /home/builder/opt/libraries/latest -logger humantags -fqbn arduino:avr:nano:cpu=atmega328 -build-cache /tmp -build-path /tmp/740561557/build -verbose -prefs runtime.tools.avrdude.path=/home/builder/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino14 -prefs runtime.tools.linuxuploader.path=/home/builder/.arduino15/packages/arduino/tools/linuxuploader/1.5.1 -prefs runtime.tools.nrf5x-cl-tools.path=/home/builder/.arduino15/packages/arduino/tools/nrf5x-cl-tools/9.3.1 -prefs runtime.tools.arduino101load.path=/home/builder/.arduino15/packages/Intel/tools/arduino101load/2.0.1 -prefs runtime.tools.core2-32-poky-linux.path=/home/builder/.arduino15/packages/Intel/tools/core2-32-poky-linux/1.6.2+1.0 -prefs runtime.tools.flashpack.path=/home/builder/.arduino15/packages/Intel/tools/flashpack/2.0.0 -prefs runtime.tools.dfu-util.path=/home/builder/.arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino1 -prefs runtime.tools.x86-linux-gcc.path=/home/builder/.arduino15/packages/arduino/tools/x86-linux-gcc/7.2.0 -prefs runtime.tools.CMSIS.path=/home/builder/.arduino15/packages/arduino/tools/CMSIS/4.5.0 -prefs runtime.tools.arduinoOTA.path=/home/builder/.arduino15/packages/arduino/tools/arduinoOTA/1.2.1 -prefs runtime.tools.bossac.path=/home/builder/.arduino15/packages/industruino/tools/bossac/1.7.0-industruino -prefs runtime.tools.sketchUploader.path=/home/builder/.arduino15/packages/Intel/tools/sketchUploader/1.6.2+1.0 -prefs runtime.tools.arm-none-eabi-gcc.path=/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs runtime.tools.arm-linux-gcc.path=/home/builder/.arduino15/packages/arduino/tools/arm-linux-gcc/4.9.3 -prefs runtime.tools.avr-gcc.path=/home/builder/.arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs runtime.tools.CMSIS-Atmel.path=/home/builder/.arduino15/packages/arduino/tools/CMSIS-Atmel/1.2.0 -prefs runtime.tools.arc-elf32.path=/home/builder/.arduino15/packages/Intel/tools/arc-elf32/1.6.9+1.0.1 -prefs runtime.tools.i586-poky-linux-uclibc.path=/home/builder/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0 -prefs runtime.tools.openocd.path=/home/builder/.arduino15/packages/arduino/tools/openocd/0.10.0-arduino7 -libraries /tmp/740561557/custom -libraries /tmp/740561557/pinned /tmp/740561557/Utalent_V1_0

Sketch uses 2592 bytes (8%) of program storage space. Maximum is 30720 bytes.

Global variables use 218 bytes (10%) of dynamic memory, leaving 1830 bytes for local variables. Maximum is 2048 bytes.

Validating license ...

Free trial (expires in 30 days)

Programming with: avrgirl-arduino flash -f undefined -a nano (new bootloader) -p /dev/ttyUSB0


reset complete.

flashing, please wait...

flash complete.



I had this issue initially.
Changed settings of the board to Nano 328P (old Bootloader) fixed it.


Today we got the same message in our class, changing to old boatloader sometimes solved the problem but most of the times it stayed. Our students had two hours to complete the first step today and they haveto continue with further steps next week, but now our entire timing is wasted.

Can somebody please suggest a possible solution so we can get to work next week?

The students were working with arduina nano on HP chromebooks, ChromeOS 74.
I had the same problem with arduina nano on Lenovo chromebook, ChromeOS 75.


Hi Everyone,

We've just published v1.0.15 of the Create Chrome app to address this.

You can visit chrome://extensions to check which version you are at, there's an update button on that page to manually update, if that doesn't work you can also try to reboot the Chrome OS device.

Please let us know if you have any further issues.


Having the same problem.  Tried rebooting board, rebooting chromebook, verifying my chrome os is up to date, etc.

  Sending3020: receiveData timeout after 400ms
Just installed v1.0.15.
ChromeOS 75.0.3770.102
Acer Chromebook 14

I just paid for the subscription based on your post above that the issue is fixed.

Please advise, are you actively working to fix this?  If not, I'd like to make a decision
on whether to terminate the subscription, as this is DOA for me.

Also, just wondering, can I configure it to wait longer than 400ms for a reply?




Aug 13, 2019, 09:28 am Last Edit: Aug 13, 2019, 11:05 am by BikerMark
The issue is back again, and therefore: so am I. :smiley-confuse:
I made progress with Arduino, and recently succeeded in flashing an ATTiny25. I had to upload a bootloader (micronucleus) first to get the clock in sync with my UNO as ISP.

Since the time-out issue of this topic was sometimes fixed by switching to the old bootloader, I wonder whether this could be the solution to the problem. If so, it could be an idea to provide here an appropiate bootloader which could be uploaded to any defective devices (read Nanos)?

Seen the number of reads of this issue (>13K now); it's an urgent one.

EDIT: Found a clue: defective device! Today I opened up a new Nano, flashed it to see whether defective or not (it was not) and then soldered the headers with my solder iron. I noticed a little shabby work on my side; needed to reheat some pins twice or even more.
After soldering the time-out issue came up again. So this seems to be the cause of the issue. Before soldering: no problemo! After soldering: 400ms time-out problem!

I'll now attach pins on another one (bought 10 in one lot) in my reflow oven and update this post again when done...

EDIT2: Done. What I thought: no problemo after reflowing the pin headers. So this whole thing might be invoked by soldering too hot/too long. I suspect it's the crystal on board that's pretty close to the pins to be soldered. I'll try and replace them on my defective boards (now I have three of them).

Go Up