Go Down

Topic: 3D printer upgrades and Arduino/Marlin problem (Read 795 times) previous topic - next topic


Hi! Please help!
After having changed the T0 and T1 thermistors for thermocoples (first two pins are for thermocouples on the board), and properly set, PID Autotune, etc, I still get the weirdest thing:
So I open Repetier, then I connect to the printer, I can see Bed temperature reading find, Head 1 and 2 reading fine, M119 and all 3 endstops are open, I then Home all Axis (they home all fine, they trigger the edstops then go back and forth)
BUT THEN I CAN'T MOVE THE AXIS NO MORE: when I click buttons to move any axis (ex X+50) or send G1 X50 for example, Repetier shows the new position (X:  50.00) but the motors didn't move. Same thing with all 3 axis no matter what move or command,, it will show the new virtual position but physically it hasn't moved. Oh, every time I send a move command, I can hear the electrical tention in the motor(s) but they don't move.
I also tried slicing something and starting a print, It homes, heats up the bed and head, then on the screen it starts printing (it shows the moves and I can hear the electric tentsion changing in the motors) but in physical reality NOTHING is moving, extruder not extruding... nothing.
Oh, I can manually extrude filament when the nozzle temperature is prime (I mean with the repetier interface button to extrude filament),, that works,,, but the heads won't move! And there are only 3 endstops, not 6.
Been stuck on this for 3 days.. I dunno if the problem is on the Arduino Mega board, or if it's a bad USB cable,, or if it's Repetier,,, or if it's the choice of ''Tools -- Programmer'' when I upload from Arduino,,,, or if it's the version problem between Arduino and older Marlin language (I did install the older version AVR board library to be able to upload this (old) code as is with my thermocouple mods)
Please help :(


Update: on the Repeteier Forum Repetier says

''Sounds like a problem in your Marlin or it's configuration. Since you hear something happening host does send the command and then it is up to firmware to execute.
We are no Marlin experts, so I can not say why homing would work and normal moves not. As homing works it means motors are working and wired correctly.''

This might help :)


None of this seems relevant to the Arduino Forum.

Two or three hours spent thinking and reading documentation solves most programming problems.

Go Up