Go Down

Topic: Alimentación NodeMCU...  (Read 1 time) previous topic - next topic

juanmagc

Hola a todos!!

No sé si esta consulta va aquí o en el apartado de Hardware... lo siento por adelantado.

Tengo un proyecto de monitorización y control de Relés con NodeMCU y cada vez que lo desconecto de la alimentación... al volverlo a conectar tengo que volver a volcar el código para que se conecte y sincronice con la página externa (cayenne).

Os ha pasado en algún proyecto?? No se queda el código en el NodeMCU?? Que hago!!!???  :smiley-confuse:

Gracias!!!!

juanmagc

Ya está solucionado. Por si os puede interesar:

Funciona todo correcto siempre y cuando se "encienda" el NodeMCU sin los sensores conectados y éstos se conecten después. Por lo que parece no puede conectarse a la Wifi con los sensores...

No me parece lo mejor, pero al menos así me funciona.

Si se os ocurre "algo" para no tener que desconectar y conectar cada vez os agradecería que me ayudarais.

Saludos.

Danicap

Se me ocurre que tienes insuficiente alimentación. Cuando hace la conexión WiFi tiene un pico de consumo, al tener los sensores conectados estos están ya teniendo un consumo y el conusmo de éstos mas el pico generado de la conexión es mayor que el aporte de intensidad que puede dar tu fuente.
Cuando los desconectas el sistema si que es capaz de dar el pico de conexión del WiFi por lo que si conecta, y al conectar después los sensores el consumo de éstos mas el consumo medio del WiFi es menor que el aporte de intensidad que da tu fuente.

Cómo lo estas alimentando?

Un saludo!

juanmagc

Hola Danicap,

Gracias por tu respuesta. También lo pensé y hice algunas pruebas...

Ahora está estable conectado todo a una fuente externa (vía proto), de donde se alimenta también el NodeMCU por la salida USB de la alimentación de la proto. Teóricamente debería tener suficiente para conectar y alimentar los sensores.

Tengo conectado un DHT11, un fotoresistor y dos relés (que no consumen nada).. y el NodeMCU.

Miraré de conectarlo todo con una pila de 9v ya que entiendo que la alimentación de la proto estará limitada a 5v y según lo que me dices, igual hace un pico inicial y no es capaz de levantar la wifi... ¿te parece buena idea o pongo en riesgo algo?

Gracias!!!!

Danicap

No, una pila de 9V apenas te va a dar amperaje, no es tema de tensión si no de corriente. Si lo tienes a una fuente de alimentación no debería de ser el problema la falta de corriente, a menos que sea una fuente muy limitada y de pocos mA. El consumo del Wifi no debría exceder 300mA de pico y los sensores que tienes no tienen mucho consumo, tirando por lo alto ponle 100mA más (tirando muy por lo alto) con una fuente que fuera capaz de dar 400mA bastaría

surbyte

Porque no sigues el consejo de alfredomrh en este hilo Bloqueo placa ESP32
En el post #5 dice

Quote
Kolban en su libro sobre ESP32 recomienda colocar un capacitor de 10 microfaradios entre el negativo y el positivo que alimenta la placa, pues dice que al transmitir por wifi consume mucha energia y esto puede generar rizos en la fuente de alimentación. Supongo que se conecta el positivo del capacitor al cable que entra al pin 3.3v de la placa y el negativo del capacitor al cable que va a tierra y esto funciona como un reservorio de energia que evita fluctuaciones que pueden causar problemas.

Esto es lo que dice...

When the ESP32 starts to transmit over wireless, that can draw a lot of current which
can cause ripples in your power supply. You may also have other sensors or devices
connected to your supply as well. These fluctuations in the voltage can cause
problems. It is strongly recommended that you place a 10 micro farad capacitor
between +ve and -ve as close to your ESP32 as you can. This will provide a reservoir
of power to even out any transient ripples. This is one of those tips that you ignore at
your peril. Everything may work just fine without the capacitor ... until it doesn't or until
you start getting intermittent problems and are at a loss to explain them. Let me put it
this way, for the few cents it costs and the zero harm it does, why not?

juanmagc

Hola,

Muchas gracias... ahora lo entiendo... seguro que es lo que comentáis que el "pico inicial" que necesita la wifi es demasiado para tal y como lo tengo montado...

Miraré el tema del capacitor de 10 microfaradios...

GRACIAS!!!

surbyte

Es importante que sea la solución. Muchos han registrado el problema. Yo mismo pero lo resolví de manera encubierta con otra fuente. Y ahora resulta que era el pico y un simple capacitor lo resuelve.
Quedaremos atentos a tu devolución.

Go Up