Go Down

Topic: Problema de inicio de programa (Read 677 times) previous topic - next topic

amsb

Nov 29, 2017, 03:28 am Last Edit: Nov 29, 2017, 02:00 pm by surbyte Reason: Errores y/o códigos van con etiquetas </>
Tengo un problema. Acabo de realizar un programa en arduino y  al querer iniciar el programa en computadora me aparecen los siguientes comunicados:

Code: [Select]
Arduino:1.6.5 (Windows 7), Placa:"Arduino Uno"

Sketch uses 3.294 bytes (10%) of program storage space. Maximum is 32.256 bytes.

Global variables use 278 bytes (13%) of dynamic memory, leaving 1.770 bytes for local variables. Maximum is 2.048 bytes.

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xf9

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xf9

Problema subiendo a la placa. Visita http://www.arduino.cc/en/Guide/Troubleshooting#upload para sugerencias.

 This report would have more information with
 "Show verbose output during compilation"
 activala desde Archivo > Preferencias

tauro0221

Hi,
Como se te puede ayudar si no provees el sketch.

rodripelto

Hola,

Primero asegura que la placa seleccionada en el IDE es la placa que intentas programar.

Segundo comprueba que el puerto serie asignado a arduino es el mismo que has seleccionado en el IDE.

Si persisten los problemas o todo es correcto reistalala IDE y/o Java.

Por cierto la vesión del IDE actual es la 1.8.5 siempre se recomienda usar las últimas versiones.

Un saludo.
Si alguna respuesta ha solucionado tu problema, da las gracias marcándola como solucionada.

surbyte

Yo tengo la version 1.6.11 sin problemas, porque afirmas eso de tener la ultima versión?

Si usas una librería nueva me parece bien tener una version de IDE acorde pero de lo contrario no hay razón para ir de la mano con los cambios.

Segun tu error
Quote
avrdude stk500_getsync() not in sync resp=0xf9
estas son las posibles soluciones

Quote
A wire is connected to pin0
You have the wrong COM port selected (the IDE does not see your board)
Your Arduino drivers are not set properly.
Un cable conectado a pin0
Tienes un mal COM port seleccionado (el IDE no puede ver tu placa)
Tus drivers Arduino no estan seteado correctamente.


rodripelto

Por supueto, yo no he dicho que una versión anterior no funcione, he puesto se recomienda siempre usar la última versión, recomendar no es obligar y por supuesto no le he puesto instala la última versión.

Volviendo a la recomendación no a la boligación seras la unica persona en el mundo mundial que no recomiende y repito recomendar no es obligar, a usar las versiones mas actualizades, tanto de ides de desarrollo, sistemas operativos y sofware en generar.

Mis primeras opciones han sido revisar placa y revisar com

Y luego como recomendación no obligación he comentado lo de la versión del IDE
Si alguna respuesta ha solucionado tu problema, da las gracias marcándola como solucionada.

surbyte

#5
Nov 29, 2017, 05:10 pm Last Edit: Nov 29, 2017, 05:24 pm by surbyte
Tu estas desde hace un tiempo corto rodripelto pero quieres mirar hace 1 año o dos cuando todos los que usaban versiones actualizadas tenian problemas con la ultima version del IDE y debian bajar de versión?

No digo cosas porque si. Tengo IDE 1.6.11 en esta PC y 1.8.X en otra (notebook), no se que version en mi notebook LINUX. Alterno con todas, aunque casi todo mi trabajo lo hago con Sublime Text + DEVIOT + PlatformIO y este si esta actualizado al dia o no funciona, asi que eso va con tu argumento de estar actualizado pero es por un tema de PlatformIO que solo agrega mas y mas placas estilo Arduino.

De ningun modo me puedes decir que si una PC no se puede comunicar debidamente con un Arduino hay que cambiar la versión del IDE. No tiene que ver con eso según mi punto de vista.

Antes hay que descartar si tu Windows esta actualizado, si tu JAVA esta actualizado, si no tienes algun problema en la PC, además de todo lo que ya has afirmado que comparto.

Pero si pruebas todo y no funciona yo tmb he aconsejado no en este caso instalar de nuevo el IDE. En realidad esta sugerencia esconder problemas en el driver u otro problema lejos de nuestra capacidad de comprensión o análisis.  Como corupción por algun corte o mal apagado de la PC.

EDITO: busco que es puntualmente el error 0xf9, no lo puedo encontrar.
EDITO 2: no existe error 0xf9 es solo una especie de CRC que aun no confirmo bien.
Encontré esto:

Quote
Después de hacer pruebas llego a la conclusión de que el PROBLEMA SE SOLUCIONA pulsando el botón reset de la placa Arduino, justo cuando está acabando de compilar y antes de comenzar la carga del código en la placa Arduino.

Go Up