Go Down

Topic: [SOLUCIONADO] Valvula, rele...Y arduino se Resetea (Read 470 times) previous topic - next topic

cascade

Nov 29, 2017, 01:23 pm Last Edit: Nov 30, 2017, 06:00 pm by cascade
Buenos dias.
Tenfo un problema con mi montaje.

Todo va correctamente hasta que conecto una electrovalvula de solenoide (12V 1A cuando abre) conectado a un Shield de 4 reles. A futuros seguramente haya 1 valvula a cada relé

La base de 12 voltios a cada rele es la misma, y la tierra de los dispositivos conectados a cada uno es siempre la misma.

El caso es que cuando activo o desactivo arduino se resetea casi al momento.

He visto esta entrada:
Link

Y por casualidad tengo algunos diodo IN4007 rodando en casa.

Mi cuestión es la siguiente.
¿Tengo que poner un diodo a cada Valvula o lo podría poner a la alimentación común  uniendo el catodo del positvo de alimentacion y el anodo con el negativo? ¿Tendria que usar otro diodo?

[SOLUCIONADO

surbyte

Si la válvula esta funcionando con DC o sea corriente continua puedes poner el diodo entre sus bornes pero cuidando polaridad o quemaras el diodo.

Positivo al cátodo del diodo
Negativo al ánodo del diodo.

Yo usaría un lápiz marcador que deje indicado cual es el positivo y cual el negativo.


cascade

Gracias por la respuesta.
Pero mi pregunta es, dado que tengo 4 válvulas, si tengo que poner uno en los bienes de cada válvula o por el contrario podría poner uno solo en los cables comunes de las valvulas, solo interrumpidos los positivos por el shield de relés.

He de decir que también al punto común tengo enchufado el Arduino con un mb102 para dar los 5v a Arduino, sensores y SHIELD de relés.

surbyte

4 válvulas = 4 diodos.
Cada válvula tiene 2 bornes y te hablé de pintar + y - entonces 1 diodo por válvula.

Go Up