Go Down

Topic: avrdude: ser_open(): can't open device "\\.\COM3": Access is denied. (Read 281190 times) previous topic - next topic

jordanthompson

HI all,
I am using the Arduino API (version 022?) with an Uno board.  It has been working fine for days...
I was playing with interrupt timers and have somehow gotten the board into a mode where I can't upload a new app.

I had an app that was blinking an LED every 6 seconds.
Now I want to upload a simple loop/sleep app and I get the following error:
Code: [Select]

avrdude: ser_open(): can't open device "\\.\COM3": Access is denied.


I have tried rebooting my PC.
I have tried pressing the reset button for various durations, during reboot of the board, while it is running and even with no power applied same thing:
the green light goes on
the amber (L) and (TX) lights flicker and the API and Uno appear to work fine.  But then the LED on the Uno starts to blink every 6 seconds.
the (TX) amber light stays on
When this happens, the API's upload button turns orange and I get the above error.  The only way to clear the error is to unplug/plug the Uno.

Here is my new code (compiles fine):
Code: [Select]


void setup() {
  pinMode(7, OUTPUT);
}

// Main loop : empty but we have to have one...
void loop() {
  digitalWrite(7, HIGH);
  delay(1000);
  digitalWrite(7, LOW);
  delay(1000);
}


Thanks in advance for any help you can offer.


Coding Badly

The first step is to verify the Uno is presented on COM3.  Remove the Uno.  Start Device Manager.  What serial ports are listed?  Insert the Uno.  Wait a few seconds.  What serial ports are listed?

jordanthompson

WOW do I feel silly.  Somehow the board was changed from an Uno.  I changed it back to an Uno and it is working fine now.  I didn't even know this was an option, so I don't know how I did it.

thanks for your help.

Jordan

mellis

No worries.  Thanks for letting us know what was going on.

jhbower

I see this was answered, or you figured it out, but here may be another cause/solution.

For back ground: I've been running this laptop fine with a Mega 2560, no problem at all.  I don't recall installing the drivers for it, but I must have done that. Now I try to hook up an Uno (and also a Due, and a Mega ADK for Android) and get driver errors (Win 7) for all of them. I also get the avrdude error above.

Apparently you may need to install additional drivers for the various boards. With your arduino board plugged in, click on the windows usb hardware button down on the taskbar, right click and select update driver, then direct it to your arduino drivers folder. Once windows knows there are arduino drivers there it seems to find the other boards without much help.

nivesh

Hi,
i just purchased an ezlcd 303 with Uno on it. There is no respond and handshake during test on Termie (code like CLS, PING) despite COM port, baud rate has been checked.

For IDE test i get the following error:
avrdude: ser_open(): can't open device "\\.\COM3": Access is denied.
 
Thanks.

agcsoft

The real problem is ..... "THE F.... DRIVER"

This works for my Arduino UNO and Nano, both Chinese generic

http://www.wch.cn/download/CH341SER_ZIP.html




terry777

solution!!!!
1. device manager
2. select ports
3. select port of arduino board examle : com1 ... com3 whatever it is
4. right click on com.
5. select properties
6. tab- port settings
7. click advanced
8. com port number- select new port number that is not in use.
9. confirm..
save and continue

the problem is a conflict between hardware devices, ie. the port is now used by another hardware device, mouse, ect..

rubikfast

THis is the Best Solution, So far ! And it Works !

http://www.fabrian.web.id/2016/01/uploading-sketch-problem-arduino.html

RoshanICV

Thanx Jordan!It worked succesfully exactly as per your instructions!!My UNO was not being detected in the computer..but after i disconnected the uno from the computer and reconnected it worked and succesfully loaded the program!(First Project) :)  :)

potatomagnet1

I'm also having this problem but i can't find the device manager anywhere.

codlink

//LiNK

Kurius

@terry777 thank you! Your solution worked for me.  It was a COM port # conflict.  Changing the COM number did the trick!

RomeoDelta

In my case, none of this worked. Turns out the problem was that Windows Update for Win10 "updated" my USB host controller and the new driver malfunctioned, but only in a few specific cases, the use of an Arduino Uno being one of them. The fix was to uninstall the driver and reinstall the manufacturer-supplied driver. Just one more thing to look at in the event you have this issue.

RD7

Go Up