Go Down

Topic: Arduino, Xbee y Matlab (Read 607 times) previous topic - next topic

yeboga

Saludos, actualmente estoy trabajando en un proyecto donde hago adquisición de datos de sensores, con la placa Arduino NANO y el software de Matlab (mediante una GUI). Cuando la placa está conectada a mi PC por cable todo funciona muy bien; pero el objetivo de mi proyecto es realizarlo de manera inalámbrica. Aquí es donde tengo el problema ya que no logro que Matlab me reconozca el Arduino con el hardware que le adiciono,

Las conexiones son de este modo:

1 módulo XBee Pro SC2 conectado al PC en modo coordinador
1 módulo XBee Pro SC2 en modo router conectado con la placa Arduino mediante los pines (Tx y Rx) y alimentación independiente

El Arduino y el XBee no están conectados mediante una shield.

El Arduino no lo estoy programando desde el software tradicional, ya que se hace desde Matlab.

Los módulos XBee se comunican en modo transparente.

De antemano muchas gracias por su ayuda.


surbyte

#1
Dec 07, 2017, 03:23 pm Last Edit: Dec 07, 2017, 03:28 pm by surbyte
Bueno deja por un momento MATLAB e intenta con el IDE, si el IDE te reconoce un enlace XBee que debiera ser transparente es decir respetar todo lo que presenta el conector USB con el que te conectas a la PC para que ésta lo reconozca.

TX, RX estan bien. No olvides GND con Xbee y el arduino por un lado y con l. Y creo que hay alguno otro pin emulado como RTS que no estoy seguro ahora.

EDITO : olvida lo anterior

Sigue alguna de estas guias : Arduino Wireless Programming With XBee Series 1 or 2

Otro enlace que puede ayudar Tutorial: Arduino and XBee Communication

yeboga

Hola Surbyte, muchas gracias por tu ayuda. Perdón por responder tan tarde; pues veras, estuve leyendo y siguiendo los tutoriales que me pasaste pero sigo sin poder lograr la conexión :smiley-confuse:. Aun no logro saber que estoy haciendo mal y no encuentro info sobre los pines emulados que me comentas.

saludos

 

Go Up