Go Down

Topic: Arduino BT, problems to upload. avrdude: stk500_getsync... (Read 2360 times) previous topic - next topic

r2d290

Feb 09, 2011, 12:09 am Last Edit: Feb 09, 2011, 10:02 am by r2d290 Reason: 1
Hello

I've bought an Arduino BT with ATMEGA168.
I'm using Windows 7

I've paired the computer with the arduino
I've selected Tools->Board->Arduino BT w/ ATmega168
I've tried different Serial Ports, and noticed that if I select COM7, I get the following message:

Binary sketch size: 1018 bytes (of a 14336 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

If I turn of the power to the arduino , I got a message about that there are no connections between the card and the computer. So I guess I've selected the correct serial port.

I know that there are several topics about this, but I've tried different solutions for 5 hours now, so I started this topic. I realy hope that there exists an solution of this problem =)

I'm new to this, so I got no clue of how to trubleshoot this kind of problem. :)

edit: I can mention that in the beginning I had the diode on pin 13 blinking on and off each 1 second. I don't know wether this was a preset setting. Then after a while with testing I runned the "bare minimum"-program. After that, the pin 13 stopped blinking. But I can't get it to start blinking again.

Usually the diode connected to the RX0 is lighting. If I press the button on the card, the diode on RX0 stops lighting for 0.5 seconds, then it starts lighting.
The pin 13 blinks fast 3 times, and then dissapear. The tx1 is lighting for about 11 seconds.

r2d290

I got the solution: I just needed to press the reset-button each time I upload the program. But, why do I need to do this? Is there any way so that I don't need to press the reset button each time?

kevinoneal

Once the device is powered up (after a reset) the bootloader will wait for a certain amount of time before it goes about executing the program that it has stored.  This is the time span that the arduino application uses to load up your new program.

Pelgy

I'm having the same problem, but I'm using a Arduino Pro Mini 3.3 328 8Mhz with a rn-41 dip breakout.  I get the same error message as you described before.  rx to tx and tx to rx, 3.3 to vcc, gnd to gnd.  I hit the reset button right after the sketch compiles.  I'm assuming it's a timing problem.  Baud rates match, 56700.  I can enter the Bluetooth command mode.  After power up, the Arduino board blinks the green led once, and then the red power led stays lit for the duration. I've read that sketches can't be uploaded this way, but there must be a way around it.  Maybe it's the bootloader.  I'm lost and have spent hours trying to solve this.  The right COM port has been selected and the right board has been selected. HELP! Thanks. 

mellis

The baud rates of the computer and the Arduino match, or also the bluetooth module?  Because the module might have a hard-coded configuration that specifies a baud rate regardless of the one used by the computer when opening the serial port.

Pelgy

pc baud rate = bluetooth baud rate = arduino baud rate = i'm confused

I can't seem to communicate with the arduino at all.  It's fresh out of the box basically.  But I heard that the 328's were 56700 baud.

Go Up