Go Down

Topic: Problem mit Adafruit und Schrittmotor - stoppt zwischendurch (Read 300 times) previous topic - next topic

iamdirtyharry

Hallo,
ich habe mir ein Adafruit MotorShield v2.3 und zwei Schrittmotoren besorgt.
Die Stepper (https://www.amazon.de/dp/B071CGCR1N/ref=pe_3044161_185740101_TE_item) haben folgende Spezifikation:
Elektrische Spezifikation:

-Schritt Winkel: 1,8 Grad.
-Spannung: 12 V.
-Strom: 1,2 A / phase.
-Widerstand: 10.0±10%/phase.
-Induktivität: 20±20%/phase.
-Haltemoment: 68g-cm2.
-Anzahl der Draht führt: 4.
-Haltemoment: 48 min. N. cm.
-Die größte Bremse-Drehmoment: 2.6N.cm.
-Isolationsklasse: B.


Ich habe nun einen Schrittmotor angehängt und das leicht veränderte "StepperTest" hochgeladen (siehe Anhang).

Jetzt ist es aber so, dass bei den 1000 steps nach "einigen" Schritten der Motor stoppt.
Mit einigen Schritten meine ich ca. jede Sekunde bzw. bei den 1000 Schritten legt der Motor ca. 20 Stops ein. :smiley-confuse:

Ich muss auch zugeben, dass ich evtl. das Shield einmal "beleidigt" habe, weil ich unabsichtlich über die Stromversorgung vom Arduino-USB den Motor laufen lassen habe.
Am Arduino selbst liegts nicht - da habe ich ein zweites getestet.

kann mir bitte jemand helfen?
ist der Motor falsch dimensioniert?

Danke!

uwefed


iamdirtyharry

Hallo Uwe,
ja, sogar 3A:
https://www.amazon.de/dp/B074NXZZD8/ref=pe_3044161_189395811_TE_dp_1

ich habe das Netzteil auch direkt am Shield angehängt

Passen deiner Meinung nach Shield und Motor zusammen?

Wenn ja, dann fürchte ich, dass ich das Shield einmal "beleidigt" habe. Dann besorge ich mir ein Neues.
Außer es gibt noch Ideen ...

Vielen Dank
Harald

Go Up