Go Down

Topic: [SOLUCIONADO] Problema Nodemcu+relé+downlight (Read 2922 times) previous topic - next topic

DJuan

No entiendo muy bien lo que quieres decir, el downlight se alimenta de 220v directamente, luego tiene una fuente que lo transforma a, según he medido, 55v

jafox007

Es averiguar si la interferencia la mete la fuente de alimentacion al encenderse.
Conecta el Nodemcu a su fuente y conectas la fuente del led a 220 manualmente a ver si el Nodemcu se reinicia en el momento del arranque del led

DJuan

No entiendo muy bien como dices que debo hacerlo, podrías hacer un esquema o algo parecido?

Gracias.

jafox007

#18
Dec 30, 2017, 12:04 am Last Edit: Dec 30, 2017, 12:27 am by jafox007
sigue este esquema y ver si al conectar S1 se reinicia el nodemcu.


DJuan

Ok gracias, cuando vaya a casa lo probaré.

DJuan

Jafox007, he hecho la prueba y no se reinicia, pero el relé se vuelve loco, se apaga y enciende repetidamente, debe ser la fuente del led, ahora solo falta saber cómo aislar ese ruido que parece que produce.

surbyte

#21
Dec 30, 2017, 05:25 am Last Edit: Dec 30, 2017, 05:35 am by surbyte
Te dije que el rele con 3.3V no debería funcionar. Hay que ver el modo de separar las alimentaciones de led y opto/bobina por otro.

Si este es el esquema



Entonces tienes una solución entre manos.

Debes alimentar entre gnd y VCC con 5V
Debes comandar el control del rele entre GND y IN con el nodemcu

La salida es como la tienes.

de ese modo el rele trabaja a 5 y el control será a 3.3V desde el nodemcu.
Necesitas una fuente de 5V.



DJuan

Surbyte, ya he probado eso que dices, y el relé se queda siempre encendido, no obedece a lo programado, ni al pulsador ni a las órdenes por web.

jafox007

#23
Dec 30, 2017, 01:10 pm Last Edit: Dec 30, 2017, 01:16 pm by jafox007
Yo probaria esta configuracion entre el nodemcu y la placa del rele.



PD: los numeros de los pines no son los correctos.tendras que conectarlos donde corresponden.

jafox007

Yo he visto infinidad de cosas raras, puede que la seccion del cable o lo que sea al encender el led provoca un pico de consumo y baja la tension o la corriente un instante, lo justo para dar problemas, no se, yo me he encontrado cosas que he llamado a mis compañeros para tener testigo porque si no nadie me creeria.

DJuan

He actualizado el post anterior con la foto.
jafox007, y crees que se puede solucionar de alguna manera que no sea conectándolo a una base? lo tengo que meter en una caja de empotrar en la pared y cabe el nodemcu justo entre todo el cableado que hay.

jafox007

Ese tipo de bases yo las he visto con protección para sobretensiones, puede que tenga un condensador dentro que absorba ese pico bajo, puedes probar a poner uno.

Incluso como comentaba antes sobre cosas extrañas que me han llegado a pasar y que no tienen explicación, prueba a alternar los hilos de 220 del led o del nodemcu, a mí me ha pasado, que tenía un problema extraño en una piscina, cuando arrancaba el motor todo se iba al traste, los medidores de ph y cloro se volvían locos y girando la clavija de la pared, desaparecer el problema, increíble pero cierto.

DJuan

He probado eso que dices de cambiar el cableado y nada, lo mismo, que tipo de condensador crees que sería ideal?

jafox007

Como parece que el problema se propaga por los 220 yo empezaria probando con los que se usan cuando una bombilla led no se apaga del todo, un condensador de poliester 400v 470nf.

Por otro lado puedes intentar poner en la entrada del nodemcu un condensador que si se viene la fuente abajo te mantenga el nodemcu bien alimentado, durante el pico bajo mientras se recupera la fuente.

DJuan

#29
Dec 31, 2017, 01:43 pm Last Edit: Dec 31, 2017, 02:00 pm by DJuan
Pues ya tengo la solución, al parecer, el ruido producido por la fuente del led, afecta al pulsador del nodemcu, digamos que lo vuelve más sensible, lo he solucionado colocando un pequeño condensador en la entrada del pulsador, y ahora si puedo decir que funciona perfecto.

Gracias por vuestra ayuda.

P.D: Si a alguien le interesa, he hecho también la aplicación en android para poder manejarlo con el móvil, leyendo incluso el estado del relé, sabiendo si está encendido o apagado.Si alguien le interesa me lo diga y le envío el archivo .aia simplificado para que lo personalice a su gusto con APP INVENTOR.

Go Up