Go Down

Topic: UNO confirmation test? (Read 706 times) previous topic - next topic

gresleyman

Hi all.

I have recently built a Humidifier using a DHT22 + UNO R3, this works fine, at low Humidity it sends Pin 11 (My choice) High, i will use this a a relay eventually to switch on a Fogger.

My problem is this, i have decided it would be nice to have a Temperature and Humidity readout on a LCD 1602A, I have tried several times with 3 different LCD's (All 16 x 2) on 2, UNO R3 boards, without success, in anyone's experience, is it possible to get 2 u/s UNO's ?? I have tried the "BLINK" test and that's ok, My own sketch for the DHT22 is ok, am do i have faults on 2 different UNO's or am i missing something out somewhere??

Regards

Ray

Delta_G

Not sure what you're asking but yes it is possible to have that display on your UNO.  If you want helpmaking it work then come on with the code and the details. 
|| | ||| | || | ||  ~Woodstock

Please do not PM with technical questions or comments.  Keep Arduino stuff out on the boards where it belongs.

DrAzzy

Those displays work great for me, your code or connections are wrong. IIRC you needed external pullups on the I2C backpacks. Also, always swap SCL and SDA if things aren't working - I still have only slightly better than 50:50 chance of getting SCL/SDA right on the first try (same with TX/RX).
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

gresleyman

Many thanks for your help so far.

I am trying to find out if i have faulty LCD' displays or faulty UNO R3 's or it's my connections, though i have done this repeatedly for abouyt10 times now, if it's me i am doing the same thing wrong over and over again.

Before i carry out your recommendations, can you answer this -

When compiling a sketch in the IDE, the bottom of the screen reads "Compiling done" the i get a line of text in a reddish colour which reads "ARCHIVING BUILT CORE (CACHING) in c:\users\dell\AppData\local\temp\arduino_avr_uno_476461\core\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a

The next two lines are in white, i can then run the "Upload" with no problems, can anyone explain in simple English what this line in red means?

Regards

Ray

sterretje

It archives the compiled code so it does not need to be compiled the next time that you compile your sketch.

With regards to the LCD, can you get a simple example like "hello world" working?
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

gresleyman

Hi.

No, it's the Hello World i am trying to do.

Regards

Ray

sterretje

Bad connections or incorrect wiring. Double check, triple check, ...
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

gresleyman

Hi All

I have finally got my LCD sketch working, ?? big puzzle for me, i purchased a LCD 12C, followed the instructions on line, and it all works fine, (have i really got 3 duff LCD's?) Anyway i am on my way to building a Humidifier, i have so far built thus Arduino UNO R3 + DHT2 + LCD 12C, downloaded all libraries and created a sketch, it all works fine display of temp & humidity is good. So many thanks for your help.

I Now wish to incorporate A relay to go HIGH when the system detects a pre set low Humidity value, but i think this maybe the wrong Forum, so i will re post this elsewhere.

Regards

Ray

Go Up