Go Down

Topic: Geschwindigkeitsmessanlage uno  (Read 1 time) previous topic - next topic

Tommy56

Da hast Du Dir beim C&P ein blödes Zeichen in Deinen Code geholt.
Schau Dir mal die angegebenen Zeilen genau an, evtl. auch mal die Zeichenkodierung ändern (Externer Editor z.B. Notepad++) um sie zu sehen.

Das hatte ich auch mal in einem aus dem Browser kopierten Quelltext. Das war ein in UTF-8 nicht sichtbares Zeichen zwischn 2 Klammern. In ANSI konnte ich es sehen.

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

Moritz2808

Kann man diese einfach löschen ?

HotSystems

Da zeigt sich mal wieder, man sollte auch verstehen, was man kopiert und nicht einfach nur copy&paste durchführen.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Tommy56

Kann man diese einfach löschen ?
Wenn Du die Zeichen findest, ja. Aber nicht die ganze Zeile löschen ;)
Gruuß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

Tommy56

Da zeigt sich mal wieder, man sollte auch verstehen, was man kopiert und nicht einfach nur copy&paste durchführen.

Die Dinger siehst Du nicht. Wie gesaht: Bei mir waren das Zeichen zwischen 2 schließenden Klammern, die auf dem Bildschirm hintereinander ohne Zwischenraum waren.
Erst das Spielen mit der Codierung der Datei brachte sie ans Licht.
An dieser Stelle ist nichts mit verstehen. Ansonsten gebe ich Dir Recht.
Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

HotSystems

Die Dinger siehst Du nicht. Wie gesaht: Bei mir waren das Zeichen zwischen 2 schließenden Klammern, die auf dem Bildschirm hintereinander ohne Zwischenraum waren.
Erst das Spielen mit der Codierung der Datei brachte sie ans Licht.
An dieser Stelle ist nichts mit verstehen. Ansonsten gebe ich Dir Recht.
Gruß Tommy
Ok...das habe ich so allerdings noch nicht erlebt.
Dann sollte es doch funktionieren, den Text über einen einfachen Text-Editor zu kopieren, da sollten doch sämtliche Steuerzeichen weg sein.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Moritz2808

und ich muss euch bei allem recht geben hätte mich wirklich früher mit dem Thema beschäftigen sollen kann es nun aber leider nicht mehr ändern. Bin auch sehr dankbar das ihr so geduldig mit mir seit. Hab die Nichtsichtbaren Zeichen entfernt doch es erscheint die nächste Fehlermeldung:
Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Uno"

C:\Users\moppe\Documents\Arduino\jetzt\jetzt.ino: In function 'void loop()':

jetzt:177: error: expected ';' at end of input

'}'

^

jetzt:177: error: expected '}' at end of input

jetzt:177: error: expected '}' at end of input

jetzt:177: error: expected '}' at end of input

exit status 1
expected ';' at end of input

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.

Tommy56

Da hast Du zuviel gelöscht.
Wenn Du ordentlich einrückst, merkst Du die fehlenden Klammern und findest das fehlende ;

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

HotSystems

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.
Und hier steht, was du unbedingt machen solltest.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Go Up