Go Down

Topic: Boards have disappeared (Read 2844 times) previous topic - next topic

freddie43

Thanks for that speedy response pert, but how weird!

I am actually using ESP32, but just putting that on its own in the 'Additional Boards manager' field did not restore ESP32, but doing ESP32 + microbit does!

Nodoubt someone can explain why?
Greybeard programmer since the dawn of time.
Much enjoying the challenges of Arduino.

pert

I am actually using ESP32
OK, the topic was originally about ESP8266 and you only said "ESP Boards", but it makes no difference.

just putting that on its own in the 'Additional Boards manager' field did not restore ESP32, but doing ESP32 + microbit does!
By "that" do you mean the ESP32 Boards Manager URL? Did you open Boards Manager after adding the URL? That step is essential. Just adding the URL only won't make the boards show up.

freddie43

You might be right. In my haste to get my ESP boards back I didn't read my notes of how I had done it before. Loading new boards is something I have only done twice in my three years of using Arduino.

Anyway. All is working now. Thanks for your help.
Greybeard programmer since the dawn of time.
Much enjoying the challenges of Arduino.

pert

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

rexlee

#19
Apr 27, 2019, 05:32 am Last Edit: Apr 27, 2019, 07:02 am by rexlee Reason: further test done by me
New issue with boards not showing up on a laptop.
I have two PC's,
-a desktop running Linux Mint 19.1 & Arduino 1.8.9   both were upgraded to latest versions and compiling ESP8266 & ESP32 works fine before & after updates.
- a laptop that I re-installed LM19.1 & Arduino 1.8.8 and the basic Arduino IDE works fine, but, when I installed ES8266 & ESP32  cores, they do NOT show up in the Board list!
The board manager shows that they installed correctly and the files are located in home/xxx/.arduino15 directory.
Comparing the desktop & laptop files & locations, they are identical.

I have read the forum and there seems to have been some issues about where these files located including in home/Arduino/hardware.
My desktop does have a hardware folder with a ArduinoTMS32 core (but no ESP cores), but the laptop has no such folder.

For the hell of it, I added a Tiny core to both systems and predictably  the correct files were generated and placed in the same directories, in a packaging & staging folder, the boards do show up on the desktop but again DO NOT show up on the laptop!

Is this an issue with Arduino IDE 1.8.9         ?
Where should the cores ultimately finish up ?

I need the laptop for doing OTA updates.  I will try earlier IDE's, but I believe the earlier versions had problems with OTA update!

edit. 
I just tried 1.8.5 and it appears to behave the same.
I also installed Arduino under /opt but it behaves the same.
I have been trying to resolves this for a few weeks now & have done a lot of seaching for ideas.

So, I am stumped at this time!    Looking for further ideas!  

pert

Is this an issue with Arduino IDE 1.8.9         ?
It's certainly possible to successfully install and use ESP8266 and ESP32 cores on Arduino IDE 1.8.9. There have not been the massive number of reports of this sort of issue we'd expect if it was a common problem.

Where should the cores ultimately finish up ?
If you installed the latest versions via Boards Manager: home/xxx/.arduino15/packages/esp32/hardware/esp32/1.0.2 and home/xxx/.arduino15/packages/esp8266/hardware/esp8266/2.5.0. Otherwise, the version folders will have different names but all the rest of the path will be the same. The only exception would be if you installed them when the Arduino IDE was running in portable mode, in which case they would be under {Arduino IDE installation folder}/portable instead of home/xxx/.arduino15.

Some time back, we were getting occasional reports of boards installed via Boards Manager disappearing from the Tools > Board menu some time later, after initially showing in that menu. I think this was related to the server hosting the Boards Manager JSON files for those boards being unavailable intermittently. When the Arduino IDE tried to download the JSON file from the URL specified in File > Preferences Additional Boards Manager URLs, if the file was not available, the previously downloaded JSON file was deleted, which caused the boards to disappear from the Tools > Boards menu. I think that was mainly experienced with the ESP8266 boards, since their server was frequently offline. I haven't heard any reports of that for some time. I don't know if it's because of the issues with the server for the ESP8266 JSON file being resolved, or that the Arduino IDE was improved to preserve the previous JSON file if a new copy can't be downloaded. Your problem sounds a bit different to me though, so it may be completely unrelated.

rexlee

#21
Apr 27, 2019, 10:03 am Last Edit: Apr 27, 2019, 11:30 am by rexlee
Thanks Pert,
I suspect that it may be some other issue, but I am at a loss as to what!
For the hell of it, I renamed my Arduino & .arduino folder something else & then uninstalled the IDE on my desk top and the re-installed it along with the ESP cores & then rescue my sketches & libraries.   All went as expected.
That is in effect exactly what I did on the lap top, yet there is absolutely no sign of the files.

However, I do note that at the bottom of the list there is a solid BLACK down arrow, in lieu of a outlined black arrow  indicating that there should be something there and NOT the end of the list!
So, I wonder if it is some graphics issue where I just can't scroll down any further.  ????  (The laptop is a Lenovo Thinkpad 420s).

Weird things happen!  I have noticed for a while that I can't get to Reference or arduino.cc from the help menu.   I noticed half an hour ago that if I use Firefox instead of Chrome it works fine  ........   grrrr!

I will keeping on going with this & report findings here for reference.
Lee


Edit.
It does appear to be a graphics problem, but I have a work around.  I edited the avr boards .txt file to get rid of all the boards that I do not use, down to four boards.    This then allowed some of the ESP32 to show but not the ESP8266 as they are further down the list.

I have since removed all the ESP32 & ESP8266 that I do not use and now the whole board list is only about 10 boards in total.  Very nice!  Much easier to use!

The down side is that, I will have to keep backup's of the new files, as they will be clobbered with IDE updates & ESP core updates.   

jezernik

I also had this issue, with the Simblee board (Shield + RFDuino BT / ARM Chipset board) after switching to another Arduino LORA and Arduino supported Audio Board.

For Simblee I am posting the solution on how to fix this issue, as it took me a few hours to fix:

1: for additional Boards Information for Simblee, use:
http://www.slinq.eu/package_simblee_index.json

This works for Arduino 1.6.5 and earlier, but for the other Arduino versions Simblee Documentation was asking the User to use the package_simblee166_index.json version

2: for the build & upload issue "arm-none-eabi-g++": file does not exist"", one can fix this by installing additional other Arduino Board Management Files on top of Simblee; install e.g. Arduino Zero and Arduino Duo or Arduino AVR Boards Files

Saso

Marciokoko

Well this happens to me lately as well, Im on 1.8.9, the thing is that that web resource is gone!

http://arduino.esp8266.com/versions/2.4.2/package_esp8266com_index.json

is no longer up.  If you try to visit the page you'll get a 404 error.  The problem is not so much that it moved as much as they didnt tell us where they moved TO.

pert

That's what you get for not using the official URL recommended in the installation instructions:
https://github.com/esp8266/Arduino/#installing-with-boards-manager

Go Up