Go Down

Topic: MKR WAN 1300 - SAM-BA operation failed (Read 1 time) previous topic - next topic

lucdes

Feb 21, 2018, 09:45 am Last Edit: Feb 21, 2018, 03:07 pm by surbyte Reason: Use tags to show images attached.
Hi :),

I've just received the MKRWAN and I tried to upload the First Configuration sketch. This error message is always showing up <SAM-BA operation failed> but the program runs... What does that mean and how to fix it please ?

Thanks for your help.

Luc


webdax

I had the very same issue when I tried to upload the blink sketch on brand new MKR WAN 1300. When I tried the "first configuration sketch" for TTN it was the same. However I quickly noticed the upload was successful despite this message, so from that point on I ignored it. I also noticed, that after the upload the port jumped to a second port for which a device driver had been installed. For being able to see the output of the first configuration sketch, I had to manually switch back to the initial port I used for uploading. When running the sketch and entering the keyss (I was using the OTAA method for my device). After a while I got the following output produced by setup() :

Welcome to MKRWAN1300 first configuration sketch
Register to your favourite LoRa network and we are ready to go!
Your module version is: ARD-078 1.1.2
Your device EUI is: a8610axxxxxxxxx
Message sent correctly!

and the TTN device received the payload "48654C6F524120776F726C6421"

which seems to be the ascii string "HeLoRa world!". During the loop() portion confirmed uplink packets are still being sent (in about 5min intervalls), however they contain only a payload "00". During the loop() section of the sketch nothing had been written on the console monitor. So the Serial.write(modem.read()) statement didn't produce anything readable, probably because the ACK from the confirmed uplink didn't produce any readible ASCII characters. For the moment I'm not sure if this was the intention of the loop portion in the sketch.



Go Up