Go Down

Topic: Getting HC-06 back into AT-command mode? (Read 3721 times) previous topic - next topic

Nick_Pyner

#15
Oct 17, 2018, 03:48 am Last Edit: Oct 17, 2018, 03:58 am by Nick_Pyner
I submit that the summary of your facts is that now is good time to abandon the HC-06 and get HC-05, which is more versatile and usually at the same price. There is clearly something weird going on with HC-06, and all you have done is made a bad situation worse. To your points.

1. The default baud rate for both HC-05 and HC-06 is 9600. If somebody has fiddled with it and you are OK with 38400, that's fine.

2. The way things are, that is evidence that the default has been changed, but not evidence that it is really an HC-06.

3. The LED activity is normal for both but does not signify it is in AT for HC-05

4. AT is a legitimate command for both.

I don't know anything about flushing, and I don't think it is relevant.

9600 baud is the required rate for config an HC-06. Your surprise implies you are using two different baud rates for configuration, which is most likely untrue and strongly suggests you aren't configuring it at the other speed at all. This will go quite some way to explain the absence of OK after your otherwise legitimate AT command

Other than the name, your description seems to be of an HC-06, and the fact the you have succeeded in configuring it at 9600 means it is an HC-06. It may have been fiddled with and it may even be by another party, but that is irrelevant. Indeed, I don't think this fiddle is such a bad idea - just confusing. I think this is a caution worth adding to my childs' guide to HC-0x, so thanks.

What I believe other people have been describing is an HC-05. This to the point where some guy got the state signal on a pin that is the state pin on an HC-05 but not connected on an HC-06.

It appears that there are three types of HC-06 around

1. The real McCaughey, most likely on a JY-MCU board
2. Yours, called HC-06 and set to run at 38400, but otherwise apparently kosher. Backboard unknown.
3.  Logically identifiable HC-05s masquerading as HC-06, sometimes using GW-040 backboards

It could be that types 2 and 3 are from the same source.

ghettokon

Hi all, I ran into the same problem with my first HC-06 given by a friend. It worked beautifully sending and receiving data on the project. However, not so lucky when I wanted to get into the AT command mode. I tried everything mentioned here as well as other places, including the Martyn Currey website that someone kept bringing up, I couldn't get that OK to show up in my serial monitor.

I then bought two brand new ones off Amazon. With the same code and wiring, I literally just pulled the old one out and plugged the new one into the breadboard. These identical ones from Amazon worked right out of the sealed bag. I ran the code before connecting to any device, so I thought maybe it was that. I paired the new HC-06 that worked with my phone, sent a few things over with an app, disconnected it, it went right back into the AT command mode by itself!!

I didn't have luck with any of those on the first one at all. Hope this helps someone out there who are frustrated with getting into the AT command mode on a bad/cheap HC-06. It may not be your fault.


cheers,

Nick_Pyner

#17
Oct 21, 2019, 03:25 am Last Edit: Oct 21, 2019, 05:06 am by Nick_Pyner
it went right back into the AT command mode by itself!!
HC-06 is in AT mode by default, stays that way until a Bluetooth connection is made, and reverts to AT mode when the connection is broken.

Running the code before making a connection would have no bearing on the matter. I bet most HC-06s are never configured, they are just run out of the box.

It would appear that you are confirming that there are indeed some dud HC-06s around.

Go Up