Go Down

Topic: Arduino MKR 1300 WAN Upload Trouble (Read 1 time) previous topic - next topic

3Dtj

Feb 22, 2018, 01:46 am Last Edit: Feb 22, 2018, 05:24 am by Coding Badly

RE: http://forum.arduino.cc/index.php?topic=517269.0

Hey  there.  I'm followoing up on eurkea86's early posting as I'm running into the same problem for both of my new Arduino MKR 1300 WAN units.  They are fresh out of the box and for some reason I'm unable to compile the standard Blink program on either one of them.  I even bought a USB male micro connector cables from Arduino thinking there was some weird problem with the USB male micro connnectors that I already have (clearly those are going back).

I've installed the updated cores (as cited in Arduino 1300 tutorial) for the MKR 1300 WAN and I've selected AVR ISP as the programmer.  I do sporadically get a no port option error message to select a port from which is odd because I never have a problem with my Arduino UNOs.

Below is the error message that I'm getting when I try to compile the Blink program.

Code: [Select]

ketch uses 9736 bytes (3%) of program storage space. Maximum is 262144 bytes.
Atmel SMART device 0x10010005 found
Device       : ATSAMD21G18A
Chip ID      : 10010005
Version      : v2.0 [Arduino:XYZ] Nov 13 2017 18:12:39
Address      : 8192
Pages        : 3968
Page Size    : 64 bytes
Total Size   : 248KB
Planes       : 1
Lock Regions : 16
Locked       : none
Security     : false
Boot Flash   : true
BOD          : true
BOR          : true
Arduino      : FAST_CHIP_ERASE
Arduino      : FAST_MULTI_PAGE_WRITE
Arduino      : CAN_CHECKSUM_MEMORY_BUFFER
Erase flash
done in 0.831 seconds

Write 9992 bytes to flash (157 pages)

[============                  ] 40% (64/157 pages)
SAM-BA operation failed
An error occurred while uploading the sketch

[========================      ] 81% (128/157 pages)
[==============================] 100% (157/157 pages)
done in 0.092 seconds

Verify 9992 bytes of flash with checksum.
Verify successful
done in 0.028 seconds
CPU reset.

Coding Badly


@3Dtj, do not cross-post.  Other thread removed.

@3Dtj, do not hijack.  Thread split.


lucdes

Hi @3Dtj :),

I have exactly the same issue with my MKR 1300 WAN... Whatever the program I try to compile, this error is showing up. But if you take a look at the serial monitor you will see that your program is running well... That's really strange and I'd be happy to know how to fix it.

Luc

3Dtj

I just updated my IDE to 1.8.5 thinking that was the issue but nope.  Still having the an issue uploading the Blink program.  Hoping pert or somebody else chimes in to give us a tip.

Go Up