Go Down

Topic: Code 43 Impossible to connect Uno or update drivers for it. (Read 2656 times) previous topic - next topic

osstynd

Hi,
I am new to Arduino and from the introductions and guidance I read things should be easy to get started.
Well, for me it is not. After 5 hours still no luck.

When I plug in the device, the laptop (Win7) says:
"USB Device Not Recognized: One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it. For assistance in solving this problem, click thismessage"
I clicked on the message, and I see 1 Unknown device. At the bottom, it says "Recommendation: Try reconnecting the device. If Windows still does not recognize it, replace the device.

I did that a number of times, in different circumstances (e.g. with a power attached to the Arduino, also without it, etc...). No luck.

I went through different forums, tried all kinds of things but nothing helps.
In Device Manager under windows I see an Unknown device under √úSB controllers: this is the unknown device in my USB connector.
- When I ask windows to find the best driver it says "Windows has determined the driver software for your device is up to date"
- When I ask to select a driver from the "drivers" folder under "Arduino-1.8.5", including subfolders, windows replies again "Windows has determined the driver software for your device is up to date"
- When I select a specific inf file (arduino.inf or arduino UNO Rev3) through "have disk", then Windows says "Windows found driver software for your device but encountered an error while attempting to install it"
- Yet in another case I get "The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with windows for X64 based systems."
- I also tried a totally different computer: same problem.

In the mean time I continue to have error code 43: "Windows has stopped this device because it has reported problems. I also tried another laptop, still without any success. Same errors."
I see 2 leds, one is blinking rapidly, another one is simply on.

What else can I do? Return the Arduino to the shop  >:(  >:(  >:( ?

ballscrewbob

Clearly you didnt read quite as much as you say otherwise you would have supplied a little more information.

Please attach a picture of the board in focus around the USB connector.

Make sure nothing else is connected to the boards

Use a USB 2.0 port not USB 3.0.

Disable any security / antivirus for testing only.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

osstynd

Attached you find 2 pictures:
- One picture with the board in active state (but not connected to USB): L led is blinking, ON led is on.
- One picture with the USB in detail (USB cable is connected to the board, but not to the laptop)
I tried another USB cable as well, but without success.

Nothing else (except for the power supply) is connected to the board. I also disconnected other USB devices from the USB bus (mouse) to prevent interference.
I disabled all protection mechanisms (firewall, anti-virus, etc) but no luck either, still the same issue.
The board is connected to a USB 2 port indeed.

ballscrewbob

It is a clone Arduino and uses a CH 340 so you need to install these drivers to start with.

My recommendation is that you do it with driver enforcement OFF  (google that to see how to do it.)\

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

osstynd

I tried that before, but unlike most people claiming suddenly everything is ok, at my side it isn't.
It's the first time I tried it out with the option on the drivers signature though, but this didn't help either.

- When I try an update driver software, selecting the inf file of the ch341ser.zip I get a message it is not compatible.
- When I run the setup.exe, then run "install" it ends up saying "The device is successfully pre-installed in advance" as if it installs a driver but hasn't found any hardware yet.

So no luck so far.

ballscrewbob

If you got that message then usually the driver was installed correctly.

Disconnect the clone Arduino and remove anything that may be connected to it.
Restart the computer.
Open device manager
Expand ports COM & LPT
Plug in the Clone.
If it is picked up correctly a CH340 device with a COM port will show up.
And if you get that far you are almost ready to go.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

osstynd

I acted as below, but there is no such thing as "COM & LPT".
See screenshot attached.
I only see something appearing under USB (unknown device) (see second screenshot).

I already tried creating a COM port myself, type Arduino.cc / Arduino Uno, but it doesn't like up with the device on the USB.

ballscrewbob

It looks like you may have either an issue with your windows installation or are running a VM of some kind ?

Clearly you wont have as many com ports as me but you should be able to see the section as shown in the attached picture.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

osstynd

I noticed that in your case you have following serial interfaces:
- A lot of Arduinos, which I can't connect yet
- A physical serial port, which I don't have either. I have USB, HDMI, Ethernet, VGA, but no serial port.
- USB to serial, but these are CH340, so linked to Arduino.

I guess, because I don't have a physical serial port, there is no need to display anything there. If I manually add a port, I can. It becomes visible but doesn't solve the problem unfortunately.

Main question could be: why does it appear at USB level while most of the users see the device appearing as a port?

ballscrewbob

Windows will usually RESERVE a COM 1 and COM 2 internally even if there are no physical ports available.

In my list you see both REAL and CLONE arduinos.
The real ones have the name of the board plus a port and the clones all tend to show up as CH340 devices with a COM port.

The simple reason they can show up in USB devices is that they enumerate (pretend) to be a COM port once they are correctly installed.
Hence anything that is not yet correctly installed would possibly show up at a USB level.

What are you using as a computer ?

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

osstynd

My current computer is an Asus N71JQ-TY065V running Windows 7 SP1.
It's not a new one ;-) but it still works fine (and a lot faster than the new HP listed below...)

I tried on a 1,5 year old HP EliteBook 745 G3 as well, but same problem.

ieee488

You may want to update the chipset driver for your PC.
Depending on how your laptop got to be Windows 7, the chipset driver may be quite old.


Are you sure you are not connected to a USB3 port?


osstynd

The COM & LPT section simply does not exist, so I cannot expand it.
I also tried "hidden devices" but still it is not there.

ieee488

The COM & LPT section simply does not exist, so I cannot expand it.
I also tried "hidden devices" but still it is not there.
I have Windows 7 SP1, and the COM and LPT section does exist.


Drivers for your laptop.
I strongly urge updating the chipset driver. https://www.asus.com/Laptops/N71Jq/HelpDesk_Download/

osstynd

I believe this is depending on your configuration.
Here below a screenshot of my other laptop (HP): doesn't have com ports either.
It can create one if needed (I did it manually, then they are visible), but this doesn't solve the issue.


Go Up