Go Down

Topic: Yet another not in sync / unable to upload problem (Read 1 time) previous topic - next topic

ttttkk

Apr 27, 2013, 10:30 am Last Edit: Apr 27, 2013, 10:35 am by ttttkk Reason: 1
First of all, my Duemilanove with Atmega128 ran just fine. After almost a year or so, I decided to take it out to play with it a little. Then here came the bizarre problems.

When it tried to upload a sample sketch (blink) with the latest version 1.0.4, it gave me the good old [font=Verdana]"avrdude: stk500_getsync(): not in sync: resp=0x00" error[/font], but of course this still happened even with the correct COM and board selected. I then switched back to an older version I used before such as 0023, well, it didn't show the same error but it took literally FOREVER to upload the sketch,with the TX led kept on blinking. Nothing I could do except unplugging it, but when I re-pluged the cable, something odd happened. The blink sample worked! The D13 red led blinked .... for 5 sec, then the TX led took over - the D13 red led extinguished after 5 sec and the TX led blinked for about 1 min or so. At that time, the arduino desktop program didn't laucnh whatsoever. In fact, whenever I launch the arduino desktop program or plug a usb cable in my Duemilanove, the TX led will blink for the same period of time, I don't know if it is normal or not.

Already tried resetting before uploading, on different computers with different cables on different COM, but the problems still lingered.

Please help, thank  you!!

johnwasser

Sometimes a sketch will flood the USB buffers with output and cause the upload to fail.  To work around that:

Hold down the Reset button.
Unplug the USB cable (this clears the USB buffers).
Plug the USB cable back in.
Click on the Upload button for the sketch you are trying to upload.
When the Receive LED blinks, release the Reset button.

Holding the Reset button until the upload starts prevents the sketch from flooding the buffers.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

ttttkk

#2
Apr 28, 2013, 06:45 am Last Edit: Apr 28, 2013, 08:44 am by ttttkk Reason: 1
Thank you for the reply, but it didn't work.

I did as you said, when I released the reset button as the RX blinked, after a few blinks, it stopped, then the TX blinked like crazy.

P.S. I pulled out the serial monitor, noticed that the arduino kept output values, I think it have got to be something to do with my last project stored in the arduino, which keeps output something and blocks the new sketch to be stored. So I wonder if there is any way to "empty" the arduino, bring it back to default>



        System wide configuration file is "C:\Users\kin\Desktop\ANDROID\arduino-0023\arduino-0023\hardware/tools/avr/etc/avrdude.conf"

        Using Port            : \\.\COM8
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x06

Go Up