Go Down

Topic: errore nella compilazione (Read 301 times) previous topic - next topic

EnricoMatzeu

salve a tutti sono Enrico, sono nuovo nel mondo di arduino e vorrei risolvere il mio problema
utilizzo un Mega 2560, il programma non l'ho scritto io ma un mio amico, quando me l'ha inviato io ho cercato di compilarlo e inserirlo nel mio Arduino ma non riesco a compilare in quanto appare questo errore:
"no matching function for call to 'VarSpeedServo::write(int&, int)' "

gpb01

Buongiorno,
essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie. :)

Guglielmo

P.S.: Qui una serie di link utili, NON necessariamente inerenti alla tua domanda:
- serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections
- pinout delle varie schede by xxxPighi: Pinout
- link generali utili: Link Utili

Search is Your friend ... or I am Your enemy !

Silente

Senza il programma si sa poco
Dove va un numero va una variabile, una funzione e/o  un test.
Per ottenere devi spiegare

Strumenti/Formattazione automatica fino alla morte!
Cristianesimo:bibbia='C':K&R

docdoc

Eh, ma forse già gli basterebbe saper tradurre il messaggio per capire cosa e dove cercare, ma se poi il programma l'ha fatto l'amico direi che dovrebbe chiedere (quantomeno) all'amico...
Alex "docdoc" - ** se ti sono stato d'aiuto, un punto karma sarà gradito, clicca su "add" qui a sinistra, vicino al mio nome ;) **

Go Up