Go Down

Topic: Blink works with Arduino IDE +AVRDude but not with Atmel Studio7 +AVRDude (Read 525 times) previous topic - next topic

Baldilocks

Hi, I'm new here.
I started writing asm in 1968 and I've been doing it occasionally since then. Did a lot with Pascal/ Modula2 but not much for 20 years. Cis new to me.

I've got a project working that needs the speed and consistency of assembler. I also found a book (Arduino Inline Assembly by James Eli) that is written at a level that doesn't befuddle me.

My problem is that sketches that work with with the Arduino IDE and load through AVRDude work, but the same thing through Atmel studio 7 and pointing towards the same AVRDude folder appears to work, good messages etc, the RX/TX LEDs flicker on the Nano, but it keeps the previous upload and ignores the one that it should be running. - Easy enough to see as the test programs (sorry, sketches) are identical apart from the speed of blinking.

I suspect a configuration file somewhere but there are gigabytes of Studio and its rather bewildering.

Help!

Baldilocks

Solved it!

Trawling through the verbose code produced by both the Atmel Studio and Arduino IDE versions of AVRDude I noticed that Arduino (the working version) had put its own version of the 'System wide configuration file' avrdude.conf , not where the program is run from:

C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf

but from a personal folder:

C:\Users\Ian\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino9/etc/avrdude.conf

Pointing Atmel Studio at this latter file solved my problem!

On to the next insoluble problem!

Baldi

Go Up