Go Down

Topic: ESP8266 not responding (Read 2708 times) previous topic - next topic


Hi all,

I've got a problem with this little ESP8266 module. I'm using this tool for flashing (made a jumper to pull down GPIO01):
It seems that I can flash it with arduino and with nodemcu firmware programmer as well. After flashing, I remove the jumper, and plug in again this programmer, but it looks like the esp8266 does not working. I tried many example projects via arduino with no luck. Led is not blinking, no communication on serial terminal. The wifi device itself netiher can be seen. I flashed back the original firmware with the help of this site: original fimware. AT commands are not working. Has anybody faced this kind of issue?

Thanks in advance


Not sure the circuit of that programmer you bought.
If you can find the schematic, compare it to https://tttapa.github.io/ESP8266/Chap02%20-%20Hardware.html


I will, thanks for the suggestion. But otherwise, after a successful flashing it should work if I switch gnd and vcc to a 3.3V power supply, correct me if I am wrong.


Mar 31, 2018, 01:28 am Last Edit: Mar 31, 2018, 01:31 am by ieee488
When flashing I use a 3.3V power supply so I never switch.

I personally like the tutorial  https://www.allaboutcircuits.com/projects/flashing-the-ESP-01-firmware-to-SDK-v2.0.0-is-easier-now/
That's what I used.

I use a USB-TTL adapter and I built that circuit because I have the parts.
That programmer you bought should work, but they are new.

You may want to read  http://www.arjunsk.com/iot/programming-esp8266-esp-01-using-esp8266-programmer-ch340g-chip-adapter/. The photos are too small.

Also read:  https://www.esp8266.com/viewtopic.php?f=6&t=11610



I managed to debug the problem. Circuit was OK, programmer working. I noticed that at poweron the chip sends boot information on 74880 baud rate. I googled it and turned out that I used the wrong Flash mode setting. Setting it to DOUT flash mode solved the problem, ESP8266 is working.



Im Aishwarya i need help for esp8266 in the arduino atmega328p Programming declared PORTD but if i compile the same code with the espp8266(NODE MCU 1.0) its giving complier error

 how can i rectify this problem ,in place of PORTD register can i write any other one  for esp8266 board


Mar 23, 2019, 07:49 am Last Edit: Mar 23, 2019, 07:53 am by IsukapatlaTaraUsha
here is the code for interfacing esp8266 with ARDUINO UNO atmega328 to upload sensor data to THINGSPEAK API.

#include <SoftwareSerial.h>
#define RX 10
#define TX 11
String AP = "xxxxxxxxxxx";       // CHANGE ME
String PASS = "xxxxxxxxxxx"; // CHANGE ME
String API = "xxxxxxxxxxxxxxxx";   // CHANGE ME
String HOST = "api.thingspeak.com";
String PORT = "80";
String field = "field1";
int countTrueCommand;
int countTimeCommand;
boolean found = false;
int valSensor = 1;
SoftwareSerial esp8266(RX,TX);
void setup() {
  sendCommand("AT+CWJAP=\""+ AP +"\",\""+ PASS +"\"",20,"OK");

  pinMode(trigPin, OUTPUT);
  pinMode(echoPin, INPUT);
void loop() {
 valSensor = getSensorData();
 String getData = "GET /update?api_key="+ API +"&"+ field +"="+String(valSensor);
 sendCommand("AT+CIPSTART=0,\"TCP\",\""+ HOST +"\","+ PORT,15,"OK");
 sendCommand("AT+CIPSEND=0," +String(getData.length()+4),4,">");
int getSensorData(){
  return random(1000); // Replace with your sensor program
void sendCommand(String command, int maxTime, char readReplay[]) {
  Serial.print(". at command => ");
  Serial.print(" ");
  while(countTimeCommand < (maxTime*1))
      found = true;
  if(found == true)
    countTimeCommand = 0;
  if(found == false)
    countTrueCommand = 0;
    countTimeCommand = 0;
  found = false;


Go Up