Go Down

Topic: No Serial Port Opition in Windows 10 IDE (Read 3729 times) previous topic - next topic

2231puppy

Hello,
Whenever I try to use the Windows 10 Arduino IDE (not the app) to upload a sketch to my offical Arduino Uno board, I Can'tselect a serial port. When I try ayways,I get the following message:
Code: [Select]
Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Uno"


Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "\\.\COM8": The system cannot find the file specified.


Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.[code]

pert

If you open Windows Device Manager and then plug in the Uno do you see a new device appear? If so, then you probably need to install the driver, which you can find in the drivers subfolder of the Arduino IDE installation folder. If not, then you might have a defective or charge-only USB cable. Try using a different cable you know works for data or verify your cable works for data on a different device.

ieee488

I have purchased Arduino Unos from several sellers on eBay, and fortunately for me the included USB cables have all been data-capable.

The single biggest reason for this type of failure is not installing the CH340 driver.



pert

I've never gotten a bad USB cable with an Arduino board but I did buy some USB cables separately for use with an Arduino board and they turned out to not have the data cables connected though not advertised as such. It's confusing because the LEDs on the board light up so you expect it's working but then it's never recognized by the computer.

2231puppy

I found that the pdroblem is with the Arduino board itself. Thank you for the suggestions!

Go Up