Go Down

Topic: Relais (Read 380 times) previous topic - next topic

19christoph1994

Hallo zusammen,

ich möchte ein Relais mit 5V ansteuern. Das Relais ist richtig angeschlossen. Den Signalpin zum Schließen habe ich mit einem digitalen Pin 3 am Arduino Uno verbunden. Dort wird im 3 Sekunden Rhytmus ein und wieder ausgeschalten.

Mein Problem:

Obwohl am Pin des Arduinos eine Spannung anliegt, schaltet das Relais nicht. Sobald ich die Versorgungsspannung direkt an dem Signalpin anschließe, schaltet es jedoch. Kann mir also keinen Reim darauf machen, weshalb es mit dem digitalen Pin am Arduino nicht funktioniert.

Bei anderen Relais hatte ich das selbe Problem. Kann also nicht am Relais liegen. Habe es auch mit anderen Pins des Arduino probiert, wobei ich auch das Problem hatte.

Würde mich sehr über eure Hilfe freuen.

Gruß Christoph

tinman13kup

Is this a "relay" or a relay module? If it is just a relay itself, the coil will require more current than the digital pins can provide, which is why it works hooking it up to power, but not the pin. If so, you require a transistor to switch the power to the coil.
Tom
It's not a hobby if you're not having fun doing it. Step back and breathe

noiasca

Welches Relais. Link fehlt.
Wie viel A zieht das Relais?
Wie viel mA kann dein Arduino sourcen?

how to react on postings:
- post helped: provide your final sketch, say thank you & give karma.
- post not understood: Ask as long as you understand the post
- post is off topic (or you think it is): Stay to your topic. Ask again.
- else: Ask again.

combie

Würde mich sehr über eure Hilfe freuen.
Gerne!

Ich bin mir recht sicher: Du machst was falsch!
Da Code und Aufbau geheim sind,  gehe ich davon aus, dass du den Fehler selber suchen möchtest.

Also: Welche Form der Hilfe hättest du gerne?
Wer seine Meinung nie zurückzieht, liebt sich selbst mehr als die Wahrheit.

Quelle: Joseph Joubert

Serenifly

#4
Apr 14, 2018, 12:32 pm Last Edit: Apr 14, 2018, 12:32 pm by Serenifly
Wie auf Englisch gesagt, Relais oder Relais Modul? Ein nacktes Relais kannst und darfst du die nicht direkt an einem µC anschließen. Und die Relais Module sind Low-aktiv. Bei High fällt das Relais ab

uwefed

Ich hellsehe mal und sage daß ein Relais nicht direkt (ohne Transistor oder einen anderen Treiber) an ein Ausgangspin des Arduino angeschlossen werden kann.
Wenn Du Glück hast, ist der Arduino nicht kaputtgegangen.
Grüße Uwe

postmaster-ino

Hi

Meine hellseherischen Fähigkeiten sagen, daß Du nur den PullUP einschaltest und Das für das Relais(/Modul) nicht reicht.

Ausführlicher und gerichteter wäre die Hilfe (auch von den Anderen), wenn Du mehr Informationen lieferst.

MfG
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

Go Up