Go Down

Topic: Arduino Mega Connection with GSM shield (Read 1 time) previous topic - next topic


I'm having problems that Nick's post above looks extremely similar to the environment I'm working in - hence not a new post - apologies if this is wrong.
I am moving a project from an Uno to Mega as seem to be running out of memory.  Everything OK on Uno with shield plugged in to Uno (used software serial & pins 7,  8 - and 9 for restart)
I have changed the jumpers as required so use external rx/tx & using Serial2 (also tried Serial1) on the Mega.
If the shield is piggybacked on the Mega - I only get nonsense characters to Serial on the PC - and even simple Serial.print code doesn't print to Serial
If the shield is unplugged with the only change being the addition of an earth wire - everything woks perfectly

Any help or suggestions would be much appreciated as I would really like to use the shield piggybacked onto the Mega


Solved! Which I will post for anyone else who has this trouble
Inspired by Nick's comments that the shield uses
D0, D1     Hardware serial

I simply cut the 2 RX0 & TX0 header pins off - and now everything works perfectly!!!

I would be interested to know an explanation for this especially as everything worked perfectly on the Uno!


Glad to hear it is working, and I'm glad to be of inspiration, but I'm far from sure that you have done the right thing to fix the problem.(!) Having said that, you have come from a Uno and thus would certainly be familiar with the limitations of hardware serial, so I don't know what this is about. I would have thought all you need do was ensure the pin 0,1 on the phone sghield had nothing on them.

Go Up