Go Down

Topic: error uploading programmer not responding (Read 433 times) previous topic - next topic

1st235

hello guys,

so actually i have experienced same error, it was caused by rx-tx pins. but now its different i dont use any of that pins. when the first time it showed no errors after few uploads it stuck with this error. i tried to unplug every pins that connect but still the same. i have checked the port and board its 100% same with board that i use. Arduino UNO and i use IDE in fedora, i have tried also in windows but still stuck with this error. and i did this with 3 arduino unos and all of them stuck with this error.

i have searched many forums but still no solutions. any idea what happen? could it be the code? or the IDE or the board itself that doesnt respond to any sketch i upload?

or is there any way to "restore everything to default"?

sterretje

Maybe your post was split away of another thread. But it's currently missing all details.

So post the full error message that you get.
Which version of the IDE?
Which version of Fedora?
Have you tried the loop back test?
Is this an original with 16U2 ttl2usb chip or a clone with e.g. CH340 or ftdi?

Not knowing the error message makes it difficult to know what's happening. If the Arduino board has a corrupted bootloader, you can restore it by burning the bootloader; you need a second Arduino or a programmer for that (if I'm not mistaken).
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

1st235

#2
Apr 19, 2018, 12:58 pm Last Edit: Apr 19, 2018, 01:01 pm by 1st235
thanks for the reply btw.

yes i have tried loopback test as instructed within this sub forum. So yes, i didnt even get the reply or echoed any data from the arduino. So i can conclude that the arduino board somehow "broken".

i have tried uploading via master-slave connection too but still not fix anything yet.

I think i use newest version of fedora and 1.8.5 version of arduino IDE. And i have no idea if my board is original or clone one but i attach the picture here.

https://drive.google.com/open?id=0B2mDV9uKEUtVN3NOQnBUWUNpeEZUVUV1N1dIdjl1SmJ4MTVJ

pert


pert

Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

sterretje

If the loopback test fails, your communication path is broken.

Some possibly causes:
Wrong serial port selected.
USB-to-serial chip broken; does anything show in dmesg when yiu connect/disconnect?
Bad USB cable or bad contacts.

What is a master/slave connection?
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

1st235

#6
Apr 20, 2018, 10:37 am Last Edit: Apr 20, 2018, 10:38 am by 1st235
Quote
Arduino: 1.8.5 (Linux), Board: "Arduino/Genuino Uno"
/home/vergil/Downloads/arduino-1.8.5/arduino-builder -dump-prefs -logger=machine -hardware /home/vergil/Downloads/arduino-1.8.5/hardware -tools /home/vergil/Downloads/arduino-1.8.5/tools-builder -tools /home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -built-in-libraries /home/vergil/Downloads/arduino-1.8.5/libraries -libraries /home/vergil/Arduino/libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path /tmp/arduino_build_691282 -warnings=none -build-cache /tmp/arduino_cache_440803 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -prefs=runtime.tools.arduinoOTA.path=/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -prefs=runtime.tools.avr-gcc.path=/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -verbose /home/vergil/Downloads/arduino-1.8.5/examples/01.Basics/Blink/Blink.ino
/home/vergil/Downloads/arduino-1.8.5/arduino-builder -compile -logger=machine -hardware /home/vergil/Downloads/arduino-1.8.5/hardware -tools /home/vergil/Downloads/arduino-1.8.5/tools-builder -tools /home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -built-in-libraries /home/vergil/Downloads/arduino-1.8.5/libraries -libraries /home/vergil/Arduino/libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path /tmp/arduino_build_691282 -warnings=none -build-cache /tmp/arduino_cache_440803 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -prefs=runtime.tools.arduinoOTA.path=/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -prefs=runtime.tools.avr-gcc.path=/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr -verbose /home/vergil/Downloads/arduino-1.8.5/examples/01.Basics/Blink/Blink.ino
Using board 'uno' from platform in folder: /home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr
Using core 'arduino' from platform in folder: /home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr
Detecting libraries used...
"/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-I/home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr/cores/arduino" "-I/home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr/variants/standard" "/tmp/arduino_build_691282/sketch/Blink.ino.cpp" -o "/dev/null"
Generating function prototypes...
"/home/vergil/Downloads/arduino-1.8.5
/hardware/tools/avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-I/home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr/cores/arduino" "-I/home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr/variants/standard" "/tmp/arduino_build_691282/sketch/Blink.ino.cpp" -o "/tmp/arduino_build_691282/preproc/ctags_target_for_gcc_minus_e.cpp"
"/home/vergil/Downloads/arduino-1.8.5/tools-builder/ctags/5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "/tmp/arduino_build_691282/preproc/ctags_target_for_gcc_minus_e.cpp"
Compiling sketch...
"/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-I/home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr/cores/arduino" "-I/home/vergil/Downloads/arduino-1.8.5/hardware/arduino/avr/variants/standard" "/tmp/arduino_build_691282/sketch/Blink.ino.cpp" -o "/tmp/arduino_build_691282/sketch/Blink.ino.cpp.o"
Compiling libraries...
Compiling core...
Using precompiled core
Linking everything together...
"/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p  -o "/tmp/arduino_build_691282/Blink.ino.elf" "/tmp/arduino_build_691282/sketch/Blink.ino.cpp.o" "/tmp/arduino_build_691282/../arduino_cache_440803/core/core_arduino_avr_uno_6a56a3534200c70a8f1948e281849a6e.a" "-L/tmp/arduino_build_691282" -lm
"/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0  "/tmp/arduino_build_691282/Blink.ino.elf" "/tmp/arduino_build_691282/Blink.ino.eep"
"/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avr-objcopy" -O ihex -R .eeprom  "/tmp/arduino_build_691282/Blink.ino.elf" "/tmp/arduino_build_691282/Blink.ino.hex"
Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/bin/avrdude -C/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/ttyACM0 -b115200 -D -Uflash:w:/tmp/arduino_build_691282/Blink.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 11:00:16
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/home/vergil/Downloads/arduino-1.8.5/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/vergil/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.[/quote]

here is the error code. im sorry i forgot to attach this thing.

so furthermore i have tried to change the IC but still havent fixed the problem yet. and yes i think its processing chip for communication that has been broken.

Go Up