Go Down

Topic: Funzionamento NodeMCU ESP12E (Read 387 times) previous topic - next topic

cicciozuc

Ho acquistato una Nodemcu esp-12E, quando l'ho accesa la prima volta il led a bordo lampeggiava sicuramente avranno caricato un blink per testarlo, appena ho caricato un blink in cui ho modificato i delay il led non lampeggiava più.... Ho settato correttamente l'IDE scegliendo come scheda la Nodemcu 1.0 (ESP-12 Module) qualsiasi sketch carico lo accetta ma poi non dà alcun segnale di vita...

Sbaglio qualcosa??

SukkoPera

#1
Apr 21, 2018, 11:41 am Last Edit: Apr 21, 2018, 11:41 am by SukkoPera
A quale pin supponi sia collegato il led? 13? No, mi pare sia D2, o forse 4. Provali tutti :).
"Code is read much more often than it is written, so plan accordingly. Design for readability."

Guida rapida a ESP8266: https://goo.gl/kzh62E

cicciozuc

Il led di cui parlo io è quello blu posizionato a bordo sull'esp8266 del Nodemcu.. Quando carico un blink su un'altro esp8266 esp01 il led lampeggia su Nodemcu invece niente

SukkoPera

Se ti ho detto una cosa ci sarà un perché, no?
"Code is read much more often than it is written, so plan accordingly. Design for readability."

Guida rapida a ESP8266: https://goo.gl/kzh62E

cicciozuc

Ho controllato i pin da D0 a D8 e solo D3eD4 avevano una tensione costante di 3,3v... Quindi ho modificato il blink sostituendo (LED_BUILTIN) CON D3 ho caricato e adesso su quel pin ricevo il blink.... Sarà che sto conoscendo adesso Nodemcu ma pensavo che il blink mi faceva lampeggiare il led sull'esp12E... Grazie SukkoPera

SukkoPera

Se li provi tutti dovresti trovare anche il pin di quell'altro led.
"Code is read much more often than it is written, so plan accordingly. Design for readability."

Guida rapida a ESP8266: https://goo.gl/kzh62E

Go Up