Go Down

Topic: Error compilando para la placa Arduino/Genuino Uno (Read 197 times) previous topic - next topic

soymalomalo

Buenas, estoy teniendo problemas al cargar sketch desde mi ordenador, ya que me sale todo el rato el error  compilando para la placa Arduino/Genuino Uno he probado a usar el ejemplo Blink y funciona correctamente el led se ilumina.

El caso es que en este pc he cacharreado mucho con el arduino y nunca he tenido este problema pero recientemente cambie la placa base y el disco duro y desde entonces no me funciona, sin embargo lo probé en el ordenador del trabajo y cargó el sketch a la primera. He reinstaldo todos los drives, he probado con versiones antiguas del compilador... y nada 

En el hilo forum.arduino.cc/index.php?topic=516422.0 se habla del tema y he probado lo que se indica pero tampoco funciona

¿Alguna idea de que puede suceder?

Gracias de antemano


surbyte


ArduMyth

Sería bueno saber que clase de error tienes (por saber si es algo del COM o no)

inelint

A mi me pasó algo parecido, y se solucionó cambiando la versión del IDE... (parece loco pero algunas cosas se solucionan actualizandolo, otras poniendo versiones anteriores...)

soymalomalo

Pues es un PC con windows 10, el error que me da es "El sistema no puede encontrar el archivo especificado" y he probado anteriores del IDE pero nada, el caso es que antes de formatear funcionaba bien, de hecho el ambiligt que es para lo que lo uso funciona correctamente, tambien he trasteado con la velocidad del puerto y demas pero nada

surbyte

Bueno te hice una pregunta y no la respondiste.
Ademas deberías postear el error como ya te pidió @ArduMyth

Acá todos vienen y creen que nosostros vemos su pantalla, sus errores, todo lo que ha hecho y en 3 lineas debemos comprenderlos.
Por favor Lee las normas del foro y presenta toda la información para poder brindarte una ayudar responsable como todas las que damos.

Te invito a que leas tu plantea y te pongas en nuestro lugar para comprender si has aportado toda la información de la que dispones.

Todo esto es en tu beneficio.

soymalomalo

Antes todo agradecer la labor de todas las personas del foro que se han tomado la molestia en escribirme, soy consciente de que hay que facilitar toda la informaicon posible y si repasas mi respuesta veras que he respondido a las los cuestiones que planteas, PC windows 10 (imposible que sea mac), el error que me da es "El sistema no puede encontrar el archivo especificado" no entiendo el "rapapolvo" pero igual te agradezco por dedicarme tu tiempo, un saludo.

ArduMyth

#7
Apr 24, 2018, 04:14 pm Last Edit: Apr 24, 2018, 04:16 pm by ArduMyth
@soymalomalo. No creo que sea rapapolvo del moderador, es que el error que pones ni siquiera está completo.
Cuando te de un error al compilar simplemente cópialo y primero busca en google.
No encontrando respuesta ponlo en el foro a ver si alguien puede indicarte.

¿Por casualidad el error marca un puerto COM y a continuación la frase que nos comentas?

https://forum.arduino.cc/index.php?topic=428950.0

¿Comprobación de haber seleccionado el COM correcto en el IDE de Arduino?
¿Comprobación del USB?
¿Revisado los puertos en Administrador de dispositivos (Windows)?

Saludos.

surbyte

No se que es "rapapolvo" no vivo en España, asi que sime lo traducen, será mejor. Supongo por el comentario de ArduMyth que es como un tirón de orejas, o llamado de atención. Cuesta tanto hablar en un lenguaje neutral?
Yo soy Argentino y pocas veces me verán expresarme como tal.

En fin. Solo te resalto lo que dicen las normas del foro @soymalomalo y si no te gusta, te invito a que lo leas y verás que no hacemos mas que pedirte mas y mas información porque con la que das, poco podemos decirte.

soymalomalo

#9
Apr 25, 2018, 03:44 pm Last Edit: Apr 25, 2018, 05:14 pm by surbyte
Pues el error que me sale es ese, con respecto al com y demás configuraciones ya aclaré que usando el ejemplo Blink se ilumina la luz (que es un ambiligt) por la tanto el problema entiendo que esta en el compilador, tambien hice referencia a un hilo en el que se hablaba de este tema y ya dije que había hecho todas las pruebas.

No obstante os vuelvo a agradecer que os hayáis tomado la molestia en dedicarme vuestro tiempo y os pido disculpas si no me he hecho entender.

Entiendo que para darme una respuesta ni vais a mirar ese hilo ni vais a estar viendo todos mis comentarios con atención, pero vamos creo que he sido muy especifico con todo lo que he comprobado. Aclarar que al final he usado un portatil para  subir el sketch, que ha funcionado a la primera y ya ha quedado todo correcto, si os mola decidmelo y os enseño un video del resultado 


Moderador: No repitas lo que ya te han escrito de manera completa. El quote o cita es para responder párrafos. Si le respondes a un forrero pones @forero y ya se entiende. De lo contrario el hilo se llena de basura digital.

surbyte

#10
Apr 25, 2018, 05:28 pm Last Edit: Apr 25, 2018, 05:28 pm by surbyte
@soymalomalo, comprende que nosostros desde acá tenemos que entender, visualizar, recordar si eso que explicas nos ha sucedido.
Cuando todos los que te responden te piden algún dato extra, debes tener la sensibilidad de entender que no te estamos comprendiendo y nada mas, no hay segundas lecturas.

Ahora me propuse suponer que no hay mas información y una búsqueda exhaustiva que me llevó un buen tiempo dió este resultado:

EL SISTEMA NO PUEDE ENCONTRAR EL ARCHIVO ESPECIFICADO puede ser la respuesta que buscas

Está bastante claro y coincide con lo que has aportado.

soymalomalo

Muchas gracias por la información ya no lo necesito pero puesto que te has tomado la molestia de buscar la información en cuanto tenga un momento seguiré el manual y hare todas las pruebas que indican, me aseguraré de poner todos los resultados por si puede ayudar a alguien más.

De nuevo te lo agradezco, soy usuario habitual de muchos foros y admiro a las personas que como tu ayudan desinteresadamente a gente que ni conocen, creo que es lo mejor que tiene internet, compartir. :D

surbyte

Sinceramente me preocupaba que te llevaras una mala imagen nuestra. Una que no coincide con el foro y con el sentido de colaboración que tiene.

Por eso mi comentario anterior sobre un posible malentendido.

Pero cuando alguien insiste como ocurrió contigo no hace mas que indicarme que el equivocado puede ser uno, asi que esa motivación a veces ayuda a encontrar una solucion y aprender algo mas. Ahora ambos sabemos que ese problema RARO puede resolverse y se confunde con el mismo asociado al COM que era el que SI conocíamos.

Go Up