Go Down

Topic: "Warning: Board arduino" and "Invalid library found"  (Read 740 times) previous topic - next topic

dianev

Please help me!! It is my first time using my computer to code and to upload codes to arduino uno.

I was coding musical notes to make music with a buzzer, but I forgot to change the com port before uploading. I think it was initially at com1 then when the uploading failed, I suddenly remembered changing the com ports. After changing the com port to com3, I still encounter errors.


What should I do? Will this problem damage my computer? Please help me!!    :(


These are what is written on the text console:


Arduino: 1.8.5 (Windows 8.1), Board: "Arduino Uno"

Warning: Board arduino:backup boards:ethernet doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ETHERNET
Warning: Board arduino:backup boards:diecimila doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_DIECIMILA
Warning: Board arduino:backup boards:esplora doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ESPLORA
Warning: Board arduino:backup boards:pro doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_PRO
Warning: Board arduino:backup boards:atmega168 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ATMEGA168
Warning: Board arduino:backup boards:lilypad doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_LILYPAD
Warning: Board arduino:backup boards:atmega328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ATMEGA328
Warning: Board arduino:backup boards:lilypad328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_LILYPAD328
Warning: Board arduino:backup boards:micro doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_MICRO
Warning: Board arduino:backup boards:nano doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_NANO
Warning: Board arduino:backup boards:uno doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_UNO
Warning: Board arduino:backup boards:mega doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_MEGA
Warning: Board arduino:backup boards:atmega8 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ATMEGA8
Warning: Board arduino:backup boards:robotMotor doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ROBOTMOTOR
Warning: Board arduino:backup boards:bt doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_BT
Warning: Board arduino:backup boards:LilyPadUSB doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_LILYPADUSB
Warning: Board arduino:backup boards:fio doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_FIO
Warning: Board arduino:backup boards:mini doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_MINI
Warning: Board arduino:backup boards:pro328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_PRO328
Warning: Board arduino:backup boards:bt328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_BT328
Warning: Board arduino:backup boards:mini328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_MINI328
Warning: Board arduino:backup boards:leonardo doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_LEONARDO
Warning: Board arduino:backup boards:nano328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_NANO328
Warning: Board arduino:backup boards:pro5v doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_PRO5V
Warning: Board arduino:backup boards:robotControl doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ROBOTCONTROL
Warning: Board arduino:backup boards:pro5v328 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_PRO5V328
Warning: Board arduino:backup boards:mega2560 doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_MEGA2560
recipe.preproc.macros pattern is missing

Error compiling for board Arduino Uno.
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino-master: C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino-master
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino_Demo_UNO-Mega2560: C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino_Demo_UNO-Mega2560
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\attiny: C:\Users\diane\Desktop\Documents\Arduino\libraries\attiny
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\DFRobot_SIM808-master: C:\Users\diane\Desktop\Documents\Arduino\libraries\DFRobot_SIM808-master
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\DHT-sensor: C:\Users\diane\Desktop\Documents\Arduino\libraries\DHT-sensor
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\TimeAlarms: C:\Users\diane\Desktop\Documents\Arduino\libraries\TimeAlarms
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\__MACOSX: C:\Users\diane\Desktop\Documents\Arduino\libraries\__MACOSX
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino-master: C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino-master
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino_Demo_UNO-Mega2560: C:\Users\diane\Desktop\Documents\Arduino\libraries\Arduino_Demo_UNO-Mega2560
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\attiny: C:\Users\diane\Desktop\Documents\Arduino\libraries\attiny
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\DFRobot_SIM808-master: C:\Users\diane\Desktop\Documents\Arduino\libraries\DFRobot_SIM808-master
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\DHT-sensor: C:\Users\diane\Desktop\Documents\Arduino\libraries\DHT-sensor
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\TimeAlarms: C:\Users\diane\Desktop\Documents\Arduino\libraries\TimeAlarms
Invalid library found in C:\Users\diane\Desktop\Documents\Arduino\libraries\__MACOSX: C:\Users\diane\Desktop\Documents\Arduino\libraries\__MACOSX

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Quality

Did you restart the Arduino IDE? I've done that quite a lot and I always get it working after I restart the IDE.

pert

but I forgot to change the com port before uploading. I think it was initially at com1 then when the uploading failed, I suddenly remembered changing the com ports. After changing the com port to com3, I still encounter errors.
That has absolutely nothing to do with your problem.

Will this problem damage my computer?
No.

It is my first time using my computer to code and to upload codes to arduino uno.
Then why the heck are you already mucking about with the hardware packages. These warnings show that you did something very weird:
Warning: Board arduino:backup boards:ethernet doesn't define a 'build.board' preference. Auto-set to: BACKUP BOARDS_ETHERNET
but of course you didn't happen to think it was worth mentioning this "backup boards" thing you did. So now it's time for you to explain just exactly what you did.

Once you're a bit more experienced, playing around with hardware packages is great fun but for a beginner my advice is: LEAVE THEM ALONE!!

abahli

I have exactly the same problem. I have been working all morning on a project, with arduino uno, simple stuff, and all of a sudden I have unvalid libraries messages all over the show when I want to download on the arduino uno board :


Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_264276 : D:\Olivier\Documents\Arduino\libraries\arduino_264276
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_731841 : D:\Olivier\Documents\Arduino\libraries\arduino_731841
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_93779 : D:\Olivier\Documents\Arduino\libraries\arduino_93779
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_993125 : D:\Olivier\Documents\Arduino\libraries\arduino_993125
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_264276 : D:\Olivier\Documents\Arduino\libraries\arduino_264276
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_731841 : D:\Olivier\Documents\Arduino\libraries\arduino_731841
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_93779 : D:\Olivier\Documents\Arduino\libraries\arduino_93779
Bibliothèque non valide trouvée dans D:\Olivier\Documents\Arduino\libraries\arduino_993125 : D:\Olivier\Documents\Arduino\libraries\arduino_993125





pert

I have exactly the same problem.
No, you have a completely different problem. You're having an error while uploading. dianev is having a problem while compiling.

You both happen to have some invalid library warnings but that has nothing to do with your uploading problem.

Since you haven't provided any details about the upload failure it will be impossible for anyone to help you with the problem. If you do want help then you should start a new thread and provide the full verbose output.

RPCoyle

This just happened to me also... I have just installed 1.8.8 and it started right after that. I have re-installed and wiped everything clean with no luck. I did the same install on two other computers(windows 10) with no problem...

What's up ??

pert

This just happened to me also... I have just installed 1.8.8 and it started right after that.
There are multiple issues reported in this thread so I'm not sure which one you're having. Please post the full text of any warnings or error messages you're getting and I'll see if I can help.

RPCoyle

Basically it seems like it isn't reading something correctly. I have uninstalled and re-installed the ide  in a different directory. I have looked for entries in the registry (widows 10)  and  wiped what I could find... re-intalled 1.8.6 ( the last working rev that didn't give problems.... no luck.  I have tried unzipping instead of the installer... same thing happens. I installed 1.0.6 with the installer and that rev still works but none of the newer ones.

I don't get it... what the hell could possibly be remaining on the computer to cause this problem?

below  is the  message of inspiration I ger from the IDE...


Arduino: 1.8.6 (Windows 10), Board: "Arduino Duemilanove w/ ATmega328"

Warning: Board arduino:variants:nano doesn't define a 'build.board' preference. Auto-set to: VARIANTS_NANO
Warning: Board arduino:variants:mega2560 doesn't define a 'build.board' preference. Auto-set to: VARIANTS_MEGA2560
Warning: Board arduino:variants:mega doesn't define a 'build.board' preference. Auto-set to: VARIANTS_MEGA
Warning: Board arduino:variants:mini328 doesn't define a 'build.board' preference. Auto-set to: VARIANTS_MINI328
Warning: Board arduino:variants:bt328 doesn't define a 'build.board' preference. Auto-set to: VARIANTS_BT328
Warning: Board arduino:variants:micro doesn't define a 'build.board' preference. Auto-set to: VARIANTS_MICRO
Warning: Board arduino:variants:bt doesn't define a 'build.board' preference. Auto-set to: VARIANTS_BT
Warning: Board arduino:variants:diecimila doesn't define a 'build.board' preference. Auto-set to: VARIANTS_DIECIMILA
Warning: Board arduino:variants:pro5v328 doesn't define a 'build.board' preference. Auto-set to: VARIANTS_PRO5V328
....... basically every board......

Warning: Board arduino:bootloaders:micro doesn't define a 'build.board' preference. Auto-set to: BOOTLOADERS_MICRO
Warning: Board arduino:bootloaders:mega2560 doesn't define a 'build.board' preference. Auto-set to: BOOTLOADERS_MEGA2560
Warning: Board arduino:bootloaders:robotControl doesn't define a 'build.board' preference. Auto-set to: BOOTLOADERS_ROBOTCONTROL
Warning: Board arduino:bootloaders:robotMotor doesn't define a 'build.board' preference. Auto-set to:
Warning: Board attiny:variants:attiny45-20 doesn't define a 'build.board' preference. Auto-set to: VARIANTS_ATTINY45-20

Warning: Board attiny:variants:attiny45 doesn't define a 'build.board' preference. Auto-set to: VARIANTS_ATTINY45
recipe.preproc.macros pattern is missing

Error compiling for board Arduino Duemilanove w/ ATmega328.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

The problem is caused by some outdated hardware packages you have installed on your computer. They are located at:
{sketchbook folder}/hardware/arduino
and
{sketchbook folder}/hardware/attiny

You can find the location of the sketchbook folder in the Arduino IDE at File > Preferences > Sketchbook location.

{sketchbook folder}/hardware/arduino looks to just be a copy of Arduino AVR Boards so you can probably delete it.

{sketchbook folder}/hardware/attiny has been updated to work with modern IDE versions so if you still need its ATtiny board definitions you can delete that and then reinstall by following these instructions:
http://highlowtech.org/?p=1695
However, you might consider using ATTinyCore instead since it is actively maintained and has much better support:
https://github.com/SpenceKonde/ATTinyCore

RPCoyle

Thank pert... that was the problem. I don't know why it showed up though. the hardware directory in the default location was created more than a year ago. I have done at least three upgrades since then and had no trouble till now.

Anyway I would not have thought to look there... Thanks again.

pert

You're welcome. I'm glad you were able to find the culprits.

I also found the specific warning messages you were getting very strange. The warning I would expect is the more helpful:
Code: [Select]
Could not find boards.txt in {sketchbook folder}/hardware/attiny/variants. Is it pre-1.5?
The only way I can reproduce the warnings you were getting is by moving {sketchbook folder}/hardware/attiny/boards.txt to {sketchbook folder}/hardware/attiny/variants. {sketchbook folder}/hardware/attiny/variants does not contain a boards.txt file with a default installation of the attiny hardware package.

The same applies to {sketchbook folder}/hardware/arduino, only in that case boards.txt would have needed to be copied to the {sketchbook folder}/hardware/arduino/variants and {sketchbook folder}/hardware/arduino/bootloaders.

Go Up