Go Down

Topic: Bluetooth Verbindung mit PC klappt nicht nur gekoppelt (Read 254 times) previous topic - next topic

flar2000


Hallo liebe Community,
ich möchte meinen Arduino Mega gerne mit einem HC-06 mit meinem Laptop verbinden. Dort erscheint immer nur ganz kurz verbunden und dann sofort gekoppelt. Daher kann ich auch nichts übertragen.

Kann mir jemand sagen woran das liegt bzw wie ich dieses Problem behebe?

LG,
flar2000

dony

Hallo,

Warum machst Du einen neuen Thread auf?  :o Ist der alte nicht gut genug?

Wir haben beide das selbe Problem, gut ich brauch dafür nicht dringend eine Lösung weil ich mein Roboter Auto ander steuern möchte. Allerdings wäre es ne Tolle Sache für ein anderes Projekt. Ich bin mittlerweile draufgekommen wie ich eine Koppelung und Verbindung hinbekomme, aber wirklich funktioniert es nicht, was mich gleich zum zweiten Punkt bringt. Ich hab locker um die 15-20 Windows Fenster geöffnet (und wieder geschlossen). Wo stehst Du an?

Wie auch immer... In dein Windows (Win 10, aktuelle Build), die Unterschiede sind hier teilw. gravierend, so wie in den Video, alter Thread, schaut das bei mri nicht aus. Ich bin wie folgt vorgegangen Geräte->Bluetooth und andere...->Weitere Bluetooth Einstellungen->Reiter "COM-Anschlüsse"->hinzufügen-> Eingehen und Ausgehend (PC initiert die Verbindung)->Durchsuchen->WildCat (oder HC-06)->OK->Ok->OK Und dann kam noch zwischendurch "Gerät wird eingerichtet" und "Passkey eingeben". Das hat auch alles Super Toll geklappt, hatte COM10 als Bluetooth Serial Device.
Verbindung konnte ich letztendlich doch keine herstellen aber IMO ist das der richtige Weg, jetzt mal neustarten, das ewige Windows herumgetue halt.
Wie schaut das bei Dir eigentlich aus? Wird Dein HC-06 in den Einstellungen überhaupt angezeigt, bei mir nicht, nur in den erweiterten Bluetooth Optionen. :smiley-confuse:

Übrigens... ich hab auf Dein Sketch nicht vergessen. Es zu finden ist dabei auch nicht das Problem, eher es zu testen und zu kommentieren, da wie gesagt nur _AT Befehle_ die teilw. wenig Sinn ergeben weil ich direkt an eine Adresse koppel und das Ganze ewig her ist und ich mich auch den einen oder anderen Befehl googlen muss um eine vernüftige Beschreibung zusammenschreiben zu können. Aber das braucht halt Zeit.

Grüße,
Donny
edit: auch den Link korrigiert, (wie ist den das passiert?) :smiley-confuse:
Grüße, Donny

postmaster-ino

Hi

Den Link Mal korrigiert ;)
Klick

MfG
(da standen einige http.//http://... drin)
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

Go Up