Go Down

Topic: SOLVED: MKRWAN1300 does not join multitech conduit gateway (Read 1 time) previous topic - next topic

ransomhall

I have a Multitech Conduit gateway that supports OTAA.  I used the example LoraSendAndReceive sketch on the Create website with correct secrets and regional band, and got:

Your module version is: ARD-078 1.1.2
Your device EUI is: a8610a3432478a16
Something went wrong; are you indoor? Move near a window and retry

So I know the modem started. The gateway is configured for channels 1-8. How would I set that on the MKR? Do I need to?  I have other LoRa client nodes that connect to the gateway just fine, so I know the issue is not there. Also, the MKR is only about 5 feet from the gateway. Using the antenna that came with the board (sigfox dipole). I have a 900 mhz 1/2 wave whip antenna that I can try, but this close it shouldn't matter. Any suggestions appreciated.

ransomhall

The issues was picking the correct band. After looking through the MKRWAN code I found a second US band option: US915_HYBRID.  After switching to that, all is well.

Code: [Select]
modem.begin(US915_HYBRID)

Go Up