Go Down

Topic: Need help with powering multiple 5v devices [SOLVED] (Read 373 times) previous topic - next topic

annarosenberg

May 26, 2018, 12:53 am Last Edit: May 26, 2018, 03:57 pm by annarosenberg
Hi guys,
i wanna power and control one 433mhz transmitter and one hall sensor.
I have problems powering them the same time. I only can get one to work with the
5V Pin of the Arduino UNO.

Transmitter:
5V
10 mW

Sensor:
4.5 - 24V
25 mA

Code:

Code: [Select]
#include <RH_ASK.h>
#include <SPI.h>
RH_ASK rf_driver;
 
int pushButton = 13;

void setup() {
  rf_driver.init();
  Serial.begin(9600);
  pinMode(pushButton, INPUT);  
}

void loop() {
  
  int buttonState = digitalRead(pushButton);
  const char *msg = "a";
  Serial.println(buttonState);
  delay(0);        
 
if (buttonState == 0) {
    rf_driver.send((uint8_t *)msg, strlen(msg));
    rf_driver.waitPacketSent();
    delay(0);
    Serial.println("send");
    
 }
}


Circuit:



If picture does not show up this is the link: https://ibb.co/mY33ao

Hall sensor datasheet:

https://www.mpja.com/download/a3144eul.pdf

433 mhz transmitter datasheet:

https://components101.com/433-mhz-rf-transmitter-module

TomGeorge

Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Can you post link to spec/data of your transmitter and sensor please?

Thanks.. Tom... :)
Everything runs on smoke, let the smoke out, it stops running....

annarosenberg

I edited my post i hope this is fine :)

I'm just not sure if you guys can see my circuit picture.


TomGeorge

#3
May 26, 2018, 03:23 pm Last Edit: May 26, 2018, 03:24 pm by TomGeorge
Hi,
Thanks for the information, just is good practice to add info in a new post, rather than go back and edit an earlier one.



Tom.... :)
Everything runs on smoke, let the smoke out, it stops running....

TomGeorge

Hi,
What do you mean by only getting one to work with 5V.

What happens when you connect both 5V wires from the TX and the Hall Effect to 5V on the UNO?

Have you written code JUST to test and read the HallEffect?

Have you written code JUST to test and operate the TX?

Thanks.. Tom.. :)
Everything runs on smoke, let the smoke out, it stops running....

annarosenberg

Idk what the mistake was tbh... But it works now perfectly with connecting them both on the 5V Pin...

Thank you Tom for trying to help me

The next time i post i will try to give all information the right way like you told me to.


Go Up