Go Down

Topic: Brand new arduino not working (Read 1 time) previous topic - next topic

mimo777

Tried installing arduino-0022 software from the ftdi directory for a arduino duemilanove on windows 7 on a eee pc1005hab laptop.  The device status is: "This device cannot start. (Code 10)"
saw a message indicating that 2 pins needed to be shorted.  checked the board and they are indeed shorted.  Tried downloading the driver from ftdi's webpage and that driver had the same behavior.

mimo777

Tried under UBUNTU 10.10 and dmesg reports following:
[  463.675901] usb 4-2: new full speed USB device using uhci_hcd and address 22
[  463.796087] usb 4-2: device descriptor read/64, error -71
[  464.024086] usb 4-2: device descriptor read/64, error -71
[  464.241084] usb 4-2: new full speed USB device using uhci_hcd and address 23
[  464.368101] usb 4-2: device descriptor read/64, error -71
[  464.589134] usb 4-2: device descriptor read/64, error -71
[  464.805106] usb 4-2: new full speed USB device using uhci_hcd and address 24
[  465.218258] usb 4-2: device not accepting address 24, error -71
[  465.332149] usb 4-2: new full speed USB device using uhci_hcd and address 25
[  465.741096] usb 4-2: device not accepting address 25, error -71
[  465.741135] hub 4-0:1.0: unable to enumerate USB device on port 2
when I unplug and plug back in
used apt-get install arduino.....

mellis

Can you try on a different computer?  Different USB cable?  Where'd you get the board from?

mrtaylor

for Ubuntu try the following:

sudo echo Y > /sys/module/usbcore/parameters/old_scheme_first
reboot

I got it from:
http://ubuntuforums.org/showthread.php?t=797789

Go Up