Go Down

Topic: Stepper_Motor_Issues (Read 112 times) previous topic - next topic

vanallen351

Hello World,

I'm experiencing an issue with my stepper motors on my custom built 3D printer.

The motors are stalling out/are inaccurately moving. There is no grinding sound as if the steps are off or the belts is too lose so I believe the issue is due to the power supply. I am using the Azteeg 3x Pro board powered by a 12V 30A power supply. The motors are nema 17's salvaged from a junk printer but they seem to be in good shape. I don't know the input amperage for the steppers due to how I acquired them. The 12v power supply was a cheap buy from amazon.

Is it possible the power supply is delivering inconsistent output?

I also tried using a 24V 10A power supply but the issue seemed to get worse. (this power supply was also a cheap amazon buy)

Another idea I thought might be the issue is the length of wire from motor to control board. I read that the longer the wire the stronger the resistance. I'm using about 7 ft of wiring. Any thoughts on this issue?

The only other issue would be the firmware, but I've triple checked this issue and I'm pretty sure the coding is right.



jremington

#1
May 16, 2018, 09:57 pm Last Edit: May 16, 2018, 09:57 pm by jremington
Quote
salvaged from a junk printer
Measure the motor winding resistance and report back.

Those might be high impedance motors; not good for CNC.

vanallen351

I found the motors online. Here is the link.

http://www.kysanelectronics.com/Products/Detail.php?recordID=7850

By no means am I an electrical engineer, but I think the resistance is 0.9.

Does that sound about right?

vanallen351

https://www.youtube.com/watch?v=46EoMt_Nhu0



Here's a video of the stepper motor successfully sending the bed home followed by several unsuccessful attempts.

I hope this helps.

jremington

#4
May 17, 2018, 09:58 pm Last Edit: May 17, 2018, 10:01 pm by jremington
If you are certain that this is the exact motor you have:
Quote
Kysan SKU: 1124090 Mfg: 42BYG48B-18WC55W750C
MOTOR,STEP,NEMA 17,BIPOLAR,5.5KG-CM,4.2V,1.5A,D SHAFT
1.8 DEGREE,5.5KG-CM HOLDING,750MM WIRE,385X305X245MM
then no, the winding resistance is probably not 0.9 Ohms. Most likely it is 2.8 Ohms (4.2V/1.5A). The important specification is the current rating of 1.5A.

To what value have you set the current limit on your stepper driver? It should be set as high as possible, but to no more than 1.5A.

vanallen351

Okay, I did some testing.

My drive VREF measurement is around 4.19V

Peak current can be calculated using formula

Vref = I / 2



Go Up