Go Down

Topic: problema compilazione NodeMcu Devkit (Read 331 times) previous topic - next topic

Gianky00

Buonasera,
su Gestione schede, ho scaricato l'ESP8266 by community esp8266, poi seleziono come scheda la NodeMCU 1.0 (ESP-12E module) ma compilando mi da quest'errore:
Code: [Select]
Arduino:1.8.5 (Windows 10), Scheda:"NodeMCU 1.0 (ESP-12E Module), 80 MHz, 4M (1M SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

exec: "C:\\Users\\Gianky\\AppData\\Local\\Arduino15\\packages\\esp8266\\tools\\xtensa-lx106-elf-gcc\\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-g++": file does not exist
Errore durante la compilazione per la scheda NodeMCU 1.0 (ESP-12E Module).


Ho provato a reinstallare arduino ed eseguire la procedura da capo ma niente.
Utilizzando un altro pc questo problema non me lo da..non capisco quale file non trova e come posso inserirlo..
spero in un vostro aiuto, grazie!

gpb01

Ricordo sempre che questo è il forum di Arduino.cc dove si fornisce assistenza per problemi relativi a problematiche che coinvolgono Arduino, i suoi collegamenti e la sua programmazione.

Quindi, ben vengano domande che riguardano moduli ESP8266 collegati ad Arduino :) , ma domande per moduli che nulla hanno a che vedere con Arduino, prodotti da altri produttori che hanno semplicemente utilizzato/sfruttato l'IDE per sviluppare un loro "core" e facilitare la programmazione delle loro schede, come le schede NodeMcu, sarebbe bene che venissero poste al produttore. Grazie.

Guglielmo

P.S.: Ciò non toglie che, se qualcuno avesse la risposta al tuo quesito, sicuramente cercherà di aiutarti ;)
Search is Your friend ... or I am Your enemy !

Gianky00

Mi scuso gpb, pensavo che il mio dubbio potesse essere posto in questo forum, però visto che hai dato consenso per proseguire..ho cercato e sbattuto la testa ma sono riuscito a trovare solo questa discussione:
https://github.com/esp8266/Arduino/issues/1241
dove viene posto lo stesso problema ma non capisco come hanno risolto..

gpb01

... come ho detto, la cosa migliore è sempre rivolgersi hai forum dei produttori, quindi, nel tuo caso, a quello della NodeMCU, in ogni caso, se qualcuno ha la soluzione, sicuramente te la darà ;)

Guglielmo
Search is Your friend ... or I am Your enemy !

Axl_74

#4
Dec 19, 2018, 05:03 pm Last Edit: Dec 19, 2018, 05:03 pm by Axl_74
Mi scuso gpb, pensavo che il mio dubbio potesse essere posto in questo forum, però visto che hai dato consenso per proseguire..ho cercato e sbattuto la testa ma sono riuscito a trovare solo questa discussione:
https://github.com/esp8266/Arduino/issues/1241
dove viene posto lo stesso problema ma non capisco come hanno risolto..

Riesumo :)
Ho lo stesso problema, come hai risolto..?

gpb01

>Axl_74: essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie. :)

Guglielmo

P.S.: ... e comunque, anche per te, vale la stessa risposta del mio post #3
Search is Your friend ... or I am Your enemy !

Go Up