Go Down

Topic: OpenWrt Package Manager for Yun Rev2 (Read 3831 times) previous topic - next topic


May 17, 2018, 04:50 pm Last Edit: May 17, 2018, 06:26 pm by trimchess
I bought a new Yun Rev2 board. Everything works fine unless the OpenWrt package manager. I can't install many packages I installed on my old Yun with Linino. Especially the midnight commander (mc) and some python packages.
Where can I find the needed package lists? It seems, they do not exist under downloads.arduino.cc/openwrtyun/17.11/packages/...
Thanks much for help!


No help or infos received...
I could install pip with
opkg install python-pip

But after I cant install e.g. the twilio packages with
-opkg update
-opkg install twilio

Midnight commander (mc) is in any repository, I found no way to install it. Not nice but I can live with it...

In my mind, the Rev2 is not to recommend. I can't understand why they changed from Linino (worked fine) to OpenWRT.

Are there other opinions?


i have the same problem with package ftplib ... currently search a lot ... but find nothing


To all three posters in this thread: it would be very helpful if you included the actual error messages or other output that you are seeing. With that information, we may be able to give you helpful advice. Without it, we can only guess at the problem, and we would probably be wrong.

Simply saying "it doesn't work" tells us nothing. There are many reasons why it may not work, and we have no way to narrow it down. The odds are good that that the three of you are having different problems.


I have similar issues with the Yun Rev 2. LEDEYun 17.11 installed.

Using windows, following the steps for windows installation as per this link https://github.com/aws/aws-iot-device-sdk-arduino-yun

all the opkg install commands fail.  All online suggestions I have found are not working because I suspect that they were for working the first Yun version.

For example:
opkg install distribute

fails with the following error: * opkg_install_cmd: Cannot install package distribute.

I found the following link but it does not resolve this issue:

This is the content of my opkg.conf
src/gz attitude_adjustment http://downloads.arduino.cc/openwrtyun/1/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay



I am in the same boat as luckyapollo above.  I've been trying for days to install the distribute package on the same model Yun, but get the error mentioned above. 

Following this thread in the hope advice is forthcoming.



Just subscribing to this thread since I'm in the same.

PS: It seems that the only solution that we have is to downgrade our YUN firmware version and move out from 17.11.


and how to downgrade please?
I tried several solutions but none was satisfactory
follow this post:


I am having the same issue.  I am on 17.11 and having the same issues.  So the package is available on the arduino downloads page, but doesn't seem to be compatible for some reason.


For example, for the package 'distribute'

$ wget http://downloads.arduino.cc/openwrtyun/1/packages/distribute_0.6.21-1_ar71xx.ipk

Downloading 'http://downloads.arduino.cc/openwrtyun/1/packages/distribute_0.6.21-1_ar71xx.ipk'
Connecting to
Writing to 'distribute_0.6.21-1_ar71xx.ipk'
distribute_0.6.21-1_ 100% |*******************************|   150k  0:00:00 ETA
Download completed (154232 bytes)

$ opkg install distribute_0.6.21-1_ar71xx.ipk
Unknown package 'distribute'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for distribute found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package distribute.

So, you can download it fine from the package page, but opkg won't install it, with the error being an architectural flag.

Looking at a clue here from another device, perhaps the packages aren't properly cross complied... or perhaps something in opkg.conf that could be changed to make this work???


SO - looking at the architecture of a couple other packages, it is clear the architecture we are looking for is 'mips_24kc'

Confirmed by looking at:

$ cat /etc/openwrt_release
DISTRIB_DESCRIPTION='LEDEYun 17.11 r6773+1-8dd3a6e'

BUT, I can't seem to find any other repo to find the distribute package that is cross compiled for the mips_24kg architecture.  My guess is the downloads.arduino.cc page that opkg pulls from just grabs those files from the LEDE repo.  So, if that source is down, maybe it can't get updated cross-compiled files and maybe it could fail. 


So, the referenced repo there is down... so that *might* explain the problem of the referenced opkg package on the arduino downloads page not matching the architecture, but not sure.

There is another download source for the mips_24kc architecture, and 'distribute' is not in the package list:


I really don't know what to do.. I'm not sure how one would cross-compile a given package against the architecture, and not sure how to find a workaround for distribute. 

Any other thoughts from someone with more experience here would be hugely helpful.



So after researching some more, it looks like maybe we can figure it out by compiling the distribute package for the mips_24kc architecture directly.  This would be a giant pain, but it would be one way to solve the problem.  The other issue is, where to find the source to do that compile:



I am not sure if this forum is basically dead, but got some information back from the openwrt forum. So we have to find the package somewhere else.  It isn't part of the openwrt distribution, so someone else added it for arduino for the yun.


Any ideas from anyone???


Hi Guys - I got a good reply from the git repo, this may help.


**** I might suggest to arduino anyone who may be listening to pull the faulty package 'distribute' off the arduino .ipk downloads page!! It is super confusing ****

Go Up