Go Down

Topic: Error compiling board Arduino/Genuio Uno (Read 560 times) previous topic - next topic

1Sparky2

I have a surface running windows 10 and a raspberry pi 3 that work well with the Arduino software. but its getting messy using 2 devices, so i got giving a hp folio that i just want to use for my projects .
I have a fresh install of windows 7.  Every time i try to compile i get this error

open C:\Users\Garage\Documents\Ardunio: The system cannot find the file specified.

Error compiling for board Arduino/Genuino Uno


I can see the the board and get the board info. I have updated my library.
I just cannot seem to find the info for the board. The board i am using works on the other two devices .
I've had a look online but could not find the same sort of problem.

I get the same sort of error with a mega board as well.

I have also uninstalled and reinstalled with a fresh down load and it has made no difference.
I used the windows installer with xp and up Arduino 1.8.5

Dose anyone have any ideas ??

pert

Please do this:
  • File > Preferences > Show verbose output during: > compilation (check)  > OK
  • Sketch > Verify/Compile
  • After the compilation fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

1Sparky2

Sorry but i cannot find USING CODE TAGS on the toolbar
But this is what i got



Arduino: 1.8.5 (Windows 7), Board: "Arduino/Genuino Uno"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Garage\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Garage\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Garage\Documents\Ardunio, addons,\Super_Kit_V2.0_for_Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10805 -build-path C:\Users\Garage\AppData\Local\Temp\arduino_build_359695 -warnings=none -build-cache C:\Users\Garage\AppData\Local\Temp\arduino_cache_343420 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Garage\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.1.1 -prefs=runtime.tools.avrdude.path=C:\Users\Garage\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino9 -prefs=runtime.tools.avr-gcc.path=C:\Users\Garage\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2 -verbose C:\Program Files (x86)\Arduino\examples\02.Digital\BlinkWithoutDelay\BlinkWithoutDelay.ino
open C:\Users\Garage\Documents\Ardunio: The system cannot find the file specified.

Error compiling for board Arduino/Genuino Uno.

pert

#3
Jun 01, 2018, 06:12 am Last Edit: Jun 01, 2018, 06:12 am by pert Reason: Embed image
The problem is caused by the comma in your sketchbook folder name: C:\Users\Garage\Documents\Ardunio, addons,

Please do this:
  • Rename the "C:\Users\Garage\Documents\Ardunio, addons," folder to something that doesn't contain commas.
  • (In the Arduino IDE) File > Preferences > Sketchbook location > select the new folder name > OK


The code tags button on the toolbar looks like this: </>.



If you can't see the toolbar then you might be using a browser that's not fully compatible with the Arduino forum.

1Sparky2

I am using chrome as my browser and i do not have that screen.

I changed the dir to sketch and it now compiles.

Thank you so much i wasted a week and you helped me in 30 mins

Thanks heaps

pert

I'm glad to hear I was able to help you.

I have reported the incompatibility with paths that contain ,:
https://github.com/arduino/arduino-builder/issues/276

Go Up