Go Down

Topic: UNO Trouble uploading on XP ... not in sync/ protocol error (Read 16170 times) previous topic - next topic

spycatcher2k

1.  Start -> Run -> "regedit"
2.  Nav to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
3.  With "CurrentVersion" selected, choose menu option "Edit -> New -> Key"
4.  Name the key "RunOnce"
5.  Reboot
6.  Connect Arduino and install the drivers according to the instructions.
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

karistouf

hi!
Done:
1-deleted the already existing RunOnce key
2-done creation of a new RunOnce Key then reboot
i didnt killed the existing RunonceEx key
3-plugged the UNO
driver still present > gone inside the device manager
4-uninstalled te driver
5-reinstalled it manually from the folder drivers in arduin0022
6-runed arduino 22
7-tried to upload a sketch with exactly same result: not in sync 0x30 protocol: 0x51 !

what can i do else ?

spycatcher2k

Try this :

Remove Drivers (using Device Manager)
Reboot
When Driver is asked for use the one attached
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

karistouf

hi spycatcher2k.
helas, exactly same errors. impossible to laod any sketch inside ( tested with Blin)

the binary sketch size takes a long time if the sketch is bigger to appear.
same answer: not in sync 0x30
protocol response 0x51
:smiley-fat:

spycatcher2k

Try :

press upload
wait for sketch size the show
tap reset quickly
see if it uploads

if not - i've no ideas.


Drew.
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

JimG

Having same problems, and have tried all of the suggestions (except the regedit sequence) above.  Installing and uninstalling the driver a few times, rebooting in betwixt, etc. hasn't solved it.

What finally worked for me was changing the COM port baud rate from 9600 (default) to 57600 in the Port Settings tab of the Windows device manager.

Jim


marcoce

thanks a lot, spycatcher2k!!

"press upload and
wait for sketch size the show
tap reset quickly
see if it uploads"

this works for me, problem solved!
now ide uploads perfectly;

karistouf

hi spycatcher. no that doesn t work.  ]:)

I precise that this UNO is weel working on other computers.

spycatcher2k

Quote
Having same problems, and have tried all of the suggestions (except the regedit sequence) above.  Installing and uninstalling the driver a few times, rebooting in betwixt, etc. hasn't solved it.

What finally worked for me was changing the COM port baud rate from 9600 (default) to 57600 in the Port Settings tab of the Windows device manager.

Jim


Have you tried that?
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

karistouf


karistouf

i have anotehr computer with XP and the UNO is working fine.
any way to definitively clean everything ?

karistouf

yououououou ( feeling alone, boys) ! anybody around there ?

karistouf

Hum. surely evrybody has plenty things to do in real life, but i ould like really to make my UNO work with this laptop. its beginning to be a tiring problem.
I have done everything that was suggested. without result.
Could anybody please suggest me something else ?

mellis


karistouf

yes. indeed. no driver is said to be more recent that the one in arduino0022 folder, or the inf file sended byspycatcher2k.

i begin really to disespear....

Go Up