Go Down

Topic: Error al conectar - USB desconocido (Read 2462 times) previous topic - next topic

adriansg95

Jun 05, 2018, 07:48 pm Last Edit: Jun 05, 2018, 09:41 pm by surbyte
Buenas,
Me acabo de comprar un arduino MEGA (clon chino) y me da error al conectar al ordenador. El error es el siguiente:

"Windows detuvo este dispositivo porque informó de problemas. (Código 43)

Error en una solicitud del descriptor de dispositivo USB."

He probado a instalar unos drivers (CH341SER.exe), pero el problema persiste. El led de ON y el que se encuentra junto al pin 13 funcionan con normalidad.

Un saludo y muchas gracias por su atención

PD: Adjunto captura del dispositivo tal como aparece en el Administrador de dispositivos - Controladoras de bus serie universal.


tauro0221

Hi,
Ve al windows device management  selecciona hardware and sound/device manager/ports(com & LPT). Mira a ver se ves el USB port. Seleccionalo y ve al driver. Ahi selecciona upgrade y deja que windows busque el driver para el device. Normalmente el usb es el CH340. Mira a ver que driver tiene la tarjeta y se te hara mas facil.

surbyte

Eso no funciona @tauro, no con el CH341.

Si funcionara en cuanto lo conectas el sistema lo detectaría y bajaría el driver pero hay que instalarlo manualmente.

tauro0221

#3
Jun 05, 2018, 11:47 pm Last Edit: Jun 05, 2018, 11:50 pm by tauro0221
Hi,
Aqui adjunto un link para bajar el driver. Explica que es el driver para los clones de arduino Espero que tengas suerte.
https://www.srishtirobotics.com/more/blog/154-arduino-uno-r3-clone-ch340-ch341-usb-driver

Si no sale el link de la la primera vez sigue trantando hasta que salga el link.



adriansg95

Hola otra vez
Muchas gracias por vuestras respuestas, pero no me funciona :(

He usado el CH340SER.exe y me dice "The drive is successfully pre-installed in advance!" (con el Arduino conectado), pero sigue sin reconocerlo.
En el Administrador de dispositivos no me aparece lo de Puertos (COM & LPT), solo "Dispositivo USB Desconocido" colgando de Controladoras de Bus Serie Universal. Si pincho en Actualizar controlador (ya sea manual o automáticamente), me dice que "ya están instalados los mejores controladores para este dispositivo", pero sigue sin funcionar.

PD: Es un arduino mega 2560 s48 de smraza.

tauro0221

#5
Jun 06, 2018, 03:39 pm Last Edit: Jun 06, 2018, 05:17 pm by tauro0221
Hi,
Algunas veces si tienes la tarjeta del arduino incorrecta te puede dar ese error de no recononcer el puerto.Trata te eliminar el puerto en el manager y  le dice que instale el driver otra vez. 

adriansg95

Hola otra vez,
Lo he intentado también, pero cuando lo vuelvo a conectar y le doy a actualizar controlador, el sistema me dice que ya está instalado el mejor controlador para el dispositivo (pero sigue sin funcionar).

También he probado a Cambiar configuración de instalación de dispositivos y a apagar quitando la alimentación y volver a arrancar, pero todo sin resultado.

Intentaré buscar otro ordenador donde probar la tarjeta Arduino, ya os comentaré si me funciona.
Un saludo

tauro0221

Hi,
Haz tratado otro cable de USB o otra tarjeta de arduino.

adriansg95

Problema resuelto!! Muchísimas gracias!!
La culpa la tenía el cable. Probé con el de la impresora y me funcionó.

Go Up