Go Down

Topic: Arduino UNO to breadboard (Read 149 times) previous topic - next topic

Zozo26

Hi,

I'm using the tutorial from Arduino forum website to code an ATmega328 (to basically make my own Arduino on breadboard)

https://www.arduino.cc/en/Tutorial/ArduinoToBreadboard


However the chip wont code. I've selected "Arduino uno/ geniuno board and AVRISP mkll

What have I done wrong, here are my error codes.

[Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 1574 bytes (4%) of program storage space. Maximum is 32256 bytes.
Global variables use 10 bytes (0%) of dynamic memory, leaving 2038 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xc1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xc1
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
]

Kind Regards

pert

When are you getting this error? Have you already successfully gotten through the "Burning the Bootloader" step of the tutorial?

Zozo26

I haven't burnt the boot loader because I took the ATmega328 directly out of the Arduino UNO board.
 I've successfully downloaded code onto the ATmega328 using the tutorial link above before however when I plugged my ATmega328 into my strip board along with my components and ceramic capacitors and crystal, it didn't work so I need some help.

Go Up