Go Down

Topic: "unknown protocol: c" on IDE Startup (Read 536 times) previous topic - next topic

britesc

Hi,

I have started receiving the following warning in the IDE on startup or selection of an example sketch for instance. "unknown protocol: c"

It does not appear to affect the code, the IDE or the compiled and uploaded sketch. It also only appears once when the IDE opens.

As I do not like "the unexplained" has anyone any idea what it is and how to resolve it?

Thanks and kind regards,
jB  :smiley-cool:

=====================================================
My Grandkids think I'm cool but, actually I'm partially sighted so sorry for any typos

pert

Where do you see this message?

Is that the full message? If not, then post everything.

Which version of the Arduino IDE are you using?

strixx

#2
May 09, 2019, 10:37 am Last Edit: May 09, 2019, 10:40 am by strixx
Found this thread searching for the exact same thing. And this seems to be the only relevant result when googling this issue.

The message is "unknown protocol: c", and it appears in the output part of the IDE (black frame under the code editor), with red text.
It shows after sketches are loaded in the IDE. Not after compiling or uploading the sketch.

Everything seems to be working, but it gives me a bad felling not knowing what this means...

Any one have any idea?

pert

Please do this:
  • File > Preferences
  • Click on the "Additional Boards Manager URLs" input field.
  • Press Ctrl + A. This will select all the text in the input field.
  • Press Ctrl + C. This will copy the selected text to the clipboard.
  • Paste the copied text in a reply here.

ChamodAbeywickrama

#4
Jun 04, 2019, 05:13 am Last Edit: Jun 13, 2019, 08:17 am by ChamodAbeywickrama Reason: problem solved
I have this trouble too.
Britesc, If you had fix this now please tell me how.

Thanks


====PROBLEM SOLVED======

The problem was in additional board manager URL.

VS code arduino extension had added the sketch book location to additional board manager URL because the arduino.additionalUrls property in settings.json file of VS code had set to my sketchbook location. But actually I didn't set it to that location with my concern. However I empty the arduino.additionalUrls property in settings.json file of VS code and removed that folder path from arduino IDE preferences. Then problem solved.

Thanks Community

sterretje

I have this trouble too.
Britesc, If you had fix this now please tell me how.

Thanks
Don't you like the answers in the thread that you started?

And you could have had the decency to at least provide the details that pert requested in reply #3.
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

ChamodAbeywickrama

Don't you like the answers in the thread that you started?

And you could have had the decency to at least provide the details that pert requested in reply #3.
Oh. Actually I'm new to arduino forum. I have made that question without checking answers in my thread.

Thank you for reminding.

Go Up