Go Down

Topic: board wont upload blink program! (Read 2682 times) previous topic - next topic


I keep getting errors that say

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

And it uploaded fine a week ago and now it wont even let me put a basic example program on there.


Are you making sure under Tools:Board and Tools:Serial Port that the right things are selected?
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.


Maybe you can go on my post and have a look as I have the same error + another error.


yes everything is selected correctly crossroads. i will look at your post vish. thanks for the help. i am going to keep searching for a solution!


thanks for the tip spy. but still no luck. would this problem happen bc i have once removed my atmega328 chip from my uno board?


Did you perhaps reinserte the chip backwards? I did that once  :smiley-red:


nope. i matched the notch on top with the one on the chip holder. the notch on my atmega is on the opposite side from the usb and power plug ins.


Did you remove it and once you put it back it stopped working? If so, did you insert it correctly? And by correctly I don't mean in the right direction, I mean did you insert it all the way in the socket?

One of the things that happens to me all the time is to have the serial port open and try to download... sometimes it does download half the way, but most of the times I get that same error.

Have you tried using another USB port? Another computer? Where do you have your Arduino set on? Could there be a short circuit on the board because a resistor or something like that was underneath it? Do you have voltage on your board? 
This... is a hobby.


Yes, i removed it a week ago and just used the chip with caps and crystals and once i put it back into the board, the right way pushed all the way in, and went to go change my code then i got those errors that i posted above.

I used another USB port but not another computer. It powers on and the "L" light is also lit. I dont think i have a short anywhere but i dont know how to tell. Should i just reset my UNO and try again or removed the IDE from my computer and re-install everything? thanks for all the help guys.


Mar 18, 2011, 11:40 pm Last Edit: Mar 18, 2011, 11:41 pm by spycatcher2k Reason: 1


Which arduino board are using? Which version of Arduino software.  Which operating system?


Checked the legs and all are there and not bent and its in the right way and pushed in snug all the way. No echo in the moniter when i removed the chip and connected 0 and 1. I programmed the chip on the UNO board then i removed the chip and put it onto a breadboard with the crystal and caps. I realized the code i put in was missing a command so i put it back on the board and this is when i started having these problems.

Arduino alpha 0022. Its the latest download arduino has im assuming. I have an arduino UNO with ann atmega328 chip in it. I am running Windows XP on a laptop. The programs all uploaded fine stright out of the box, i programmed the chip and removed it to a board and tried to plug it back into the UNO board and the errors started. I have even tried another ATmega328 chip, and the same results occur.

How do i reset my board completely? Thanks for the help! I really appreciate it.


So is there anywhere i can send my arduino in to get it fixed or something? My uno is still inoperable.

Go Up